Subaru WRX Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey guys im a long time lurker first time posting and only because ive searched everywhere on multiple forums and cant seem to find the answer. ive been having some lighting issues with my 03 wrx wagon i got not too long ago as insurance replacement for my 04 sedan after "hydrolocking" the engine which i dont believe and will get to bottom of at somepoint when get time to take it apart sitting in my driveway where its been sitting for months being used for parts but thats a whole other story. back to the issue ive noticed on my wagon a few minor lights dont work and i cant seem to find solutions for them anywhere from checking all fuses and replacing bulbs and looking for shorts. im hoping im just a noob and missing something totally obvious and not have a real issue. first is my parking lights in the actual headlight housing dont work at all with any switch turned on but the side markers and turn signals work fine. ive checked everyfuse and replaced the bulbs which were a pain in the ass to do and still nothing. id really like them to work for a photoshoot im doing and maybe somehow rig the fog lights to run same time without low or high beams but more importantly i get them working at all. has anyone else had this issue and im just missing something? my center interior dome light is also not working at all not just when open and close door but not working at all. even replaced with led and still nothing and like i said i check every fuse in the car and no luck. ill stop rambling on and continue with list and wait to see if can even get solution to these first. and i know i know i did search forum for past related topics and couldn't find answer or wouldn't be posting and still lurking because i know alot of members on these forums hate it when noobs sign up and register just to ask dumb questions that have been answered a million different times in different ways. i tried and i looked and found nothing so before you go and hate on me for my first post being such a lame one ### at least point me in the right direction guys


btw im sorry for the lack of introduction i just already feel like a honorable member because been browsing these forums for years as this my 3rd wrx and 5th subaru and been coming here to find answers to all my other issues so far but a few starting with these " easy " ones
 

·
Registered
Joined
·
291 Posts
Your parking lights not being on is usually from the prior owner unplugging the relay under/to the right of the glovebox, I did this as having headlined guys on in the day causes glare and I also don't like being seen at night if I'm trying to hide ;)

For your dome light, if you've checked all fuses with a dmm and they're not open, then it's a wiring issue between the fuse and he socket. I have an issue with my 02 wagon were led lights don't work, they flicker and turn off or stay on dim when the switch of off. The wires to it run to the a-pillar and they're either 2/3 wires. Grab the manual from Ken Gilbert online and start testing.

If you're near WNY I can help ya out in person


Sent from my iPhone using Tapatalk
 
1 - 2 of 2 Posts
Top