Subaru WRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all, this is my first time posting a thread on a forum so bear with me

So i have a 2015 wrx 6mt usdm. it is on a stage 2 tune from Eric @tourqued performance it has the ETS intake and has 1320 performance 3" downpipe and straight pipes the rest of the way back, boost restrictor pill is removed, and access port.

the problem i am having is that i have a major acceleration stumble that drops my dam fast when it happens. it happens almost always if on the freeway and hit 3 - 10 psi range of boost. at 40-60 %throttle. if i dont hit boost my dam will never drop and sometimes if i wot so as to get boost above 10psi fast almost like tricking the car into skipping past the stumble it wont happen or i get a lower fkl fbk reading and less dramatic or no dam drop.

im hoping someone can tell me what the issue is . i run 91 octane fuel just filled up at shell and put in a bottle of octane booster just to be safe. so its definitely not bad gas. Also just cleaned maf sensor and cleaned valves (just spray in cleaner not walnut blast) turbo and trans have 101000 miles on them and the motor was rebuilt at 80k so it has about 20k on it. the shortblock was brand new at rebuild and used my old heads and upper internals.

i will be attaching two data logs (as soon as i figure out how) that i took right after filling with good fuel as mentioned above and cleaning maf sensor. the 1st is from a fresh reflash dam at 1.000 and the second is after initial stumble and dam drop cruising at freeway speeds light acceleration low boost up to 6th gear
 

·
Registered
Joined
·
1 Posts
I am having the exact same issue. Dam drop and feedback knock only when in boost with noticeable engine bog. Have you figured out your issue?

This is freaking me out.
 
1 - 3 of 3 Posts
Top