Subaru WRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys. Just bought a modded 03 WRX with 100,000 but 60,000 on a new block. Never owned a Subaru before. It already has a couple aftermarket parts. TBE and AEM short-ram intake. Been reading scary things about the SRIs and I'm scared I'm gonna mess something up. Thinking about going to get it tuned for safety. Would love some input. :eek:
 

·
Registered
Joined
·
453 Posts
well i hope with TBE exhaust and SRI that its already been tuned...any check engine light? I would talk to the previous owner and find that out. How does it run?
 

·
Registered
Joined
·
518 Posts
It's completely worthwhile to get it tuned even if the car may have been tuned before. My car was tuned with an AccessPort before I bought it, but as the AP was not with the car, even though I know it was still married to it, I used my AP to make sure I knew what tune was done to it. You can't just trust that someone was using a good map for the car, so until I can get it actually tuned, which I'm not really sure where to go in Utah now that Cobb is in AZ, I'm leaving on an off the shelf (OTS) map. At least that way I know what is happening and it's safe. With a TBE, it needs a tune, but Boosted09 is right that it would have a check engine light (CEL) if it didn't have a tune done (generally speaking. . .). Remember, a TBE is not the same as a Cat-Back (CBE). You'll actually see a different pipe right off the turbo under the hood. If it's a single, round pipe (it still LOOKS huge even so, but it's round) then it is stock. If it's a Bell shape or looks like there are 2 pipes coming off it, then it has a downpipe. If that pipe is still stock, it's not stage 2 and doesn't HAVE to have a tune. I hope that helps you.

Regarding the intake. SRIs are okay, it's the CAI that's not good on an 02-07. It has to do with the sharp bend coming from the fender creating turbulent air at the MAF sensor. Good luck, man.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I just checked and it is a full TBE, no cat in sight. It bolts directly to the turbo. I bought the car off a dealer lot so there is no one to ask about previous tuning. There's no CEL so i hope someone did something. But on that note I have decided to go ahead and buy an Accessport and get it tuned. Thanks for the help guys
 
1 - 4 of 4 Posts
Top