Subaru WRX Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Yes, I understand this is a long post and probably TMI.

So I bought a 2004 wrx sedan that was in really rough shape a few months ago (summer 2020). I got it for $2800. I fixed all of its MANY major issues to bring it back to a driveable car. It came with a 3" turbo back exhaust-- not sure on the brand but it looks expensive. I replaced the stock up pie with an invidia catless and installed equal length headers (I know I'm sorry). The only part of the exhaust that is stock is the turbo. I've also installed a short ram intake. I bought 565cc injectors but I never installed them. The flywheel is stage 1 but I replaced the clutch and pressure plate with OEM. The trans has definitely seen better days. I've looked online to find stock 0-60 times, about 5.7 seconds has come up a few times. I have an accessport for it and have tried every tune it comes with. Stage 1 91 seems to work the best. Shifting between 2-3 causes about a 300 rpm jump in rpms between shifts.

The best 0-60 time I've gotten was 7.7 seconds, banging through gears (I don't like to do this). Roughly 15 psi peak boost which I believe is measured from the intake manifold. Good fuel pressure, wonderful compression. 190F normal operating and never over heats. Nothing seems wrong besides it doesn't seem like it's as fast as it should be. Sounds normal. Is there nothing wrong with this car in terms of performance? This is my first WRX btw so I don't know how to judge it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Some more info: there are no cats at all. The O2 sensors are connected and I believe working. No DTCs. So if im correct it's in closed loop? I also had a bov but went back to the stock bpv because the sound got annoying and I noticed boost decreased with the bov.
 
1 - 2 of 2 Posts
Top