My 1/4 mile run at Kent Pacific Raceways - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 06-28-2010, 12:09 AM
WRXtuners Member
 
gastoys's Avatar
 
Join Date: Jun 2010
Location: Washington
Posts: 7
gastoys is an unknown
My 1/4 mile run at Kent Pacific Raceways



My 60ft was horrible - 2.3 seconds need to get that down to 1.7 seconds

Did finish the 1/4 mile in 14.01 with a 99.25mph. I destroyed the 2002 Honda Prelude with a full intake, exhaust and a few other goodies.

This was a 99% Stock 2010 WRX 4 Door Sedan in Lighting Red. I threw in a H&K Filter and Amsoil 5w - 30w 100% synthetic oil.
gastoys is offline  
Sponsored Links
Advertisement
 
#2 Old 06-28-2010, 12:50 AM
Moderator
 
mosc's Avatar
 
Join Date: Mar 2005
Location: Pennsylvania
Posts: 6,472
Images: 7
mosc is a helpful contributing member
Garage
moved to videos

BTW: you let out the clutch too fast and bogged the engine's RPM's. Instead of revving so high and then releasing the clutch forcing the engine to slow down, hold a lower rev but don't let it drop as the car gets going.

04 STi 16G powered lagless fun
04 WRX: SOLD
mosc is online now  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On