Weird Problems - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-20-2016, 12:03 PM Thread Starter
WRXtuners Member
 
Join Date: Jan 2016
Posts: 1
 
Weird Problems

Hey my Name is Will. I drive a 2007 WRX. I have a problem and cant figure out how to fix it.

I will be in 3rd gear about 35 mph and give it about half throttle and about 5 lbs of boost will build and my car will rev up real loud like i am hauling ass but i will still be going 35 mph. It seems like the motor is producing power but not allowing the power to go through the tranny and to the wheels.

I replaced the boost solenoid because i was told that could be the problem but it didn't fix anything. I almost want to stop driving it but that is the only way i can get to work.

PLEASE HELP ME !!!
wwhittlesey is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-20-2016, 12:56 PM
WRXtuners Member
 
GSMNZ's Avatar
 
Join Date: Apr 2014
Location: New Hampshire
Posts: 737
     
Garage
This sounds like your clutch is slipping

05 WRX Wagon - 409 AWHP / 334 WTQ Wicked Matt Tuned
GSMNZ is offline  
post #3 of 5 Old 01-20-2016, 01:08 PM
WRXtuners Member
 
titter's Avatar
 
Join Date: Apr 2015
Location: Ontario, Canada
Posts: 1,308
           
Garage
definitely sounds like clutch slippage. time for a new one.

Bugeye EJ207 Spec C 4EAT Wagon
happiness is measured in smiles per gallon
dont forget to wave
titter is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 01-20-2016, 06:12 PM
WRXtuners Member
 
arcticscythe's Avatar
 
Join Date: Dec 2013
Location: California
Posts: 1,540
     
Garage
My default thought was clutch but you might also look for a boost leak. They can be rather loud and if your not building any boost and the RPMs are still rising at a normal rate then you might be blowing boost from one of the couplers around the inter-cooler.

- Jason
Slow is Smooth > Smooth is Fast
arcticscythe is offline  
post #5 of 5 Old 01-21-2016, 08:35 PM
WRXtuners Member
 
Join Date: May 2014
Posts: 36
 
I agree clutch kit needs replacement you can either go for aftermarket parts or OEM.
clamer is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome