uhg ebay exhaust help - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 08-16-2007, 09:58 AM
WRXtuners Member
 
Join Date: Aug 2007
Location: Pennsylvania
Posts: 20
drkramm is an unknown
uhg ebay exhaust help

well i got the ebay exhaust for my 07 wrx (cbe)
fitment is terriable i have to move shit around every where and the first resonater i had to beat to hell with a hammer cause it was rubbing on the drive shaft support (right over what appears to be a big muffler on the stock exhaust)
so i beat the crap out of it and got like a quater inch of clearance put the exhaust back on and works great but if i down shift at high rpms it sounds liek some part of the exhaust is hitting looks like its still that resonater

question is if i use the stock spring bolts will this help ? or should i jsut cut out that resonater and put in a piece of pipe ?


uhg i guess its true you get what you pay for
drkramm is offline  
Sponsored Links
Advertisement
 
#2 Old 08-16-2007, 11:55 AM
WRXtuners Member
 
JBWRX06's Avatar
 
Join Date: Jan 2007
Location: Pennsylvania
Posts: 475
Images: 6
JBWRX06 is an unknown
its ebay i think wrx's deserve a little more then ebay stuff. Leave the ebay products for the civics

Last edited by LiL Shoaf; 08-16-2007 at 06:59 PM.
JBWRX06 is offline  
#3 Old 08-16-2007, 12:10 PM
WRXtuners Member
 
Join Date: Apr 2006
Location: Minnesota
Posts: 107
ikpthegame is an unknown
well did you just get a cat back, or a tbe? also there were better ways than beating it, like longer hangers. also there is nothing wrong with some the of ebay stuff. oh and what brand did you get?
ikpthegame is offline  
#4 Old 08-16-2007, 12:20 PM
WRXtuners Member
 
Join Date: Aug 2007
Location: Pennsylvania
Posts: 20
drkramm is an unknown
its a cbe i don't remember the name he had positive feedback including ones for a wrx exhaust but oh well

im gonna weld in a piece of pipe to repalce the first resonater and see if that helps
drkramm is offline  
#5 Old 08-16-2007, 05:35 PM
WRXtuners Member
 
Join Date: Apr 2006
Location: Minnesota
Posts: 107
ikpthegame is an unknown
before you do that, are you still running the stock dp? if so that will cause it to hit the drive shaft, i had that same problem till i got my dp on. well at least that fixed my problem, gl man.
ikpthegame is offline  
#6 Old 08-16-2007, 05:47 PM
WRXtuners Member
 
Jave's Avatar
 
Join Date: Nov 2004
Location: Oklahoma
Posts: 1,577
Images: 6
Jave is more helpful than not
Quote:
Originally Posted by JBWRX06 View Post
its ebay i think wrx's deserve a little more the ebay stuff. Leave the ebay products for the civics
I would beg to differ. I bought my SSAC FMIC from Ebay and spent only $300 including shipping for something that would have normally cost me over $1k. I will agree that most "performance" parts are not worth it but a few things taht have been tried out and tested(SSAC FMIC, Ebay TBE) are worth it.

OP

I have heard great things about Ebay TBE but nothing about the CBE. Supposedly the TBE is comparable to TurboXS.

▼SbiΣ Mi▼
Jave is offline  
#7 Old 08-16-2007, 06:16 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Oregon
Posts: 26
beaterwrx is an unknown
yeah, i got the turbo back ebay exhaust. the dp was bellmouth, fit just about perfect, had all the bungs, except one was on the wrong side, it was just a quick splice.. no holes, no rattling, i think having a flex dp helps a lot with fitment. its loud, but what do u expect with no cats :eek: ?
beaterwrx is offline  
#8 Old 08-17-2007, 06:53 AM
WRXtuners Member
 
Join Date: Aug 2007
Location: Pennsylvania
Posts: 20
drkramm is an unknown
yea i have the stock dp

so i am right in thinking that the pipe is hitting that drive shaft carrier

the exhaust is decent quality and fits ok for the most part the one hanger could have been longer but i had a easy fix for that i jsut don't want it rubbing anything not only is it annoying but i don't want to burn up anything that might be in that carrier
drkramm is offline  
#9 Old 08-17-2007, 11:49 AM
WRXtuners Member
 
Join Date: Apr 2006
Location: Minnesota
Posts: 107
ikpthegame is an unknown
ya your right is it hitting there. but like i said you could always try a new DP, it helped me when i put mine on, i run the megan tbe.
ikpthegame is offline  
#10 Old 08-17-2007, 12:18 PM
WRXtuners Member
 
Join Date: Aug 2007
Location: Pennsylvania
Posts: 20
drkramm is an unknown
i don't want to kill my powertrain warrenty yet and i have not heard anything good about getting warrenty work with a downpipe installed
drkramm is offline  
#11 Old 08-17-2007, 12:18 PM
WRXtuners Member
 
Join Date: Aug 2007
Location: Pennsylvania
Posts: 20
drkramm is an unknown
but thank you for the help
drkramm is offline  
#12 Old 08-17-2007, 11:14 PM
WRXtuners Member
 
Join Date: Apr 2006
Location: Minnesota
Posts: 107
ikpthegame is an unknown
i just always change out my dp back to stock b4 going to the dealer. but good luck.
ikpthegame is offline  
#13 Old 08-25-2007, 01:32 AM
WRXtuners Member
 
Boober909's Avatar
 
Join Date: Dec 2006
Location: Alberta, Canada
Posts: 202
Images: 4
Boober909 is an unknown
yeah i have the full tbe exhaust and i put invidia up-pipe in. the only problem i had with mine was the two bolts for holding the downpipe didn't align right, so i just put a pipe clamp on to the frame so it wouldnt be able to put any weight on the turbo from bumps, and mine fit great. the only problem was that customs ripped apart the box and dinged the exhaust.. damn you customs!
Boober909 is offline  
#14 Old 08-25-2007, 09:04 AM
WRXtuners Member
 
Join Date: Aug 2007
Location: Pennsylvania
Posts: 20
drkramm is an unknown
yea i ordered the kartboy longer hangers im gonna try that should be here Wednesday hopefully i can get it back on with out it rubbing

im just getting sick of jacking the car up and crawling around on stones to get to the exhaust ( i need to pave the driveway)
drkramm is offline  
#15 Old 08-27-2007, 10:17 AM
WRXtuners Member
 
Join Date: Aug 2007
Location: Pennsylvania
Posts: 20
drkramm is an unknown
well i cut out the middle resonater and put a pipe in there with a slight bend in it and its now workin alot better not nearly as much rubbing but i still ned to get the hangers on they should be here wednesday
drkramm is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On