My STi is a John Deer - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 06-19-2007, 09:36 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: California
Posts: 6
Images: 1
DoubleTake is an unknown
Send a message via AIM to DoubleTake Send a message via Skype™ to DoubleTake
Lightbulb My STi is a John Deer

My '05 STi is mostly stocked out. I instaulled an Invidia downpipe last week, and I'm pretty sure the previous owner put ebay headers on it. I've been hearing noises that sound a lot like a john deer. Almost like my timing is off. I notice yesterday with my buddy that one of the header bolts on the passanger side was missing and one was really loose. We replace the bolts tightened them down and checked the up and down pipe bolts too. There is still a strange sound coming from the passanger side of the car right around the exhaust manifold. The manifold gasket is in good condition. If anyone has any ideas please let me know.

AIM zxmcmikexz
Kmcbrearty@tmail.com

-DT out-
DoubleTake is offline  
Sponsored Links
Advertisement
 
#2 Old 06-19-2007, 10:16 AM
WRXtuners Member
 
ArmyWRX's Avatar
 
Join Date: Sep 2006
Location: Alaska
Posts: 581
ArmyWRX is more helpful than not
Send a message via AIM to ArmyWRX Send a message via Yahoo to ArmyWRX
put new gaskets between the header and engine.... that should take care of the problem.... when the bolts arent tightend down it will ruin the gasket....
ArmyWRX is offline  
#3 Old 06-19-2007, 10:28 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: California
Posts: 6
Images: 1
DoubleTake is an unknown
Send a message via AIM to DoubleTake Send a message via Skype™ to DoubleTake
'02 wrx gasket on '05 STi?

I have the passanger side header gasket for a '02 WRX on hand will it work as a replacement for the most likely bad '05 STi gasket? I hears they changed the gaskets up in '05. Looking at the parts it looks like they are the same shape and size, unless the mystery headers have some special gasket.

-DT out-
DoubleTake is offline  
#4 Old 06-19-2007, 11:17 AM
WRXtuners Member
 
Speedogomer's Avatar
 
Join Date: Jun 2005
Location: Pennsylvania
Posts: 505
Images: 6
Speedogomer is an unknown
Send a message via AIM to Speedogomer
I guess the best bet is to try and swap the gaskets, it really does sound like you've got a leak somewhere. It could also be a bad connection/leak elsewhere in the exhaust.

-Justin, aka Gomer
(sold)-05 WRX
(new)-04 Cadillac CTS-V
Speedogomer is offline  
#5 Old 06-19-2007, 05:46 PM
WRXtuners Member
 
Join Date: Apr 2007
Location: California
Posts: 79
SurfGuruJeff is an unknown
Yeah, I've been working on the car with DoubleTake (original poster) and even after tightening the header down, it still sounds like "Baggitta Baggitta Baggitta" ha ha.

One nut was gone, and another was loose! Geez! Who the heck worked on this car, Moses from Kearny Mesa Subaru!?!?!
SurfGuruJeff is offline  
#6 Old 06-19-2007, 09:46 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: California
Posts: 6
Images: 1
DoubleTake is an unknown
Send a message via AIM to DoubleTake Send a message via Skype™ to DoubleTake
Update:

I pulled the headers and up pipe and replaced the passenger side header gasket it was pretty messed up, the car is still making the same "Baggitta.." sound, but not nearly as bad. The up pipe gasket is in good condition so that is not the issue.
DoubleTake is offline  
#7 Old 06-20-2007, 01:14 AM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
see if the headers are rubbing on the oil pan.

rollin on 17's now and they're dirty
baller_v24 is offline  
#8 Old 06-20-2007, 03:44 AM
WRXtuners Member
 
Join Date: Sep 2006
Location: Nevada
Posts: 2,245
WRXKidid775 is more helpful than not
check the welds on the header for little pinholes. the ebay units tend to leak at the welds and sometimes completely crack.

Robby
02 rex is gone.
I defected to an evo :)
Evo is gone :(
Now I got nothing.
WRXKidid775 is offline  
#9 Old 06-21-2007, 01:53 PM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
Quote:
Originally Posted by WRXKidid775 View Post
check the welds on the header for little pinholes. the ebay units tend to leak at the welds and sometimes completely crack.
That is why I would not buy Ebay parts, not so good quality

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
#10 Old 06-21-2007, 02:05 PM
WRXtuners Member
 
Join Date: Apr 2007
Location: California
Posts: 79
SurfGuruJeff is an unknown
Quote:
Originally Posted by shamrock View Post
That is why I would not buy Ebay parts, not so good quality
True that... I was under the car, too looking at those headers. To me they look like ebay headers, but I don't know for sure.
SurfGuruJeff is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On