Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Bolt-on Tech (EJ255/EJ257 2.5L '04-07 STi and '06-07 WRX) (http://www.wrxtuners.com/forums/f75/)
-   -   just installed my turboxs front mount intercooler...now it wont start (http://www.wrxtuners.com/forums/f75/just-installed-my-turboxs-front-mount-intercooler-now-wont-start-30545/)

srninjastar 04-07-2011 01:59 AM

just installed my turboxs front mount intercooler...now it wont start
 
so i instaled my turboxs front mount intercooler which wasnt very hard to do. bolted down every tbold and made sure everything was tight. so i go and take a test drive and get on it a lllliiiiitttttle bit and i here what sounds like a bov sound and then everything cuts off and my car dies. i open my hood see that the bpv is loose. tighten it up as well as any remaning tbolts. start it up and it dies. try it again and it idels really really low and my afrs are a solid 10. what the hell!? i know people usually get a tune for this but does it react that bad to where u cant even turn the car on? ima just put my stocker back on and go back and get a retune, unless someone cant point out to me exactly whats going on.

pzr2874 04-07-2011 05:44 AM

Did you clean out the pipes real well before installing them ?

Did you ever get that other boost leak fixed?

basco 04-07-2011 07:28 AM

sounds like a torn turbo inlet

baumgartenb 04-07-2011 08:08 AM

It sounds like you need to take your time when installing something major like that...just go through and check everything over really well like basco and pzr2874 said...maybe let your car idle for a few minutes to adjust to the change while checking everything over. You are using the stock bpv? make sure the recirc hose is not hitting anything and not allowing a good seal.

RcrsWetDream 04-07-2011 08:40 AM

Or just a major leak somewhere.

I have to say it, you have terrible luck.

basco 04-07-2011 08:57 AM

from everything you've described you still have a massive leak in the intake system after the MAF before the Throttle Body

basco 04-07-2011 08:59 AM

and no you don't "need" a tune for a front mount but like everything on these cars its better to get one

srninjastar 04-07-2011 09:25 AM

it came with a new bpv. ill check my turbo inlet and see if anythong is torn. i bolted down every tbolt hatd and its still actn up like this.

baumgartenb 04-07-2011 09:31 AM

[quote=srninjastar;259280]it came with a new bpv. ill check my turbo inlet and see if anythong is torn. i bolted down every tbolt hatd and its still actn up like this.[/quote]

were all your prior boost leaks fixed when you put this set up on? If so then you almost know that it has something to do with the new set up...go through everything new that you put on "clamps, hoses" and check for tightness.

pzr2874 04-07-2011 10:06 AM

Put the stock BPV back on and try it again. Unless that's what you meant by throwing the stocker back on and getting a retune?

srninjastar 04-07-2011 10:35 AM

so i tighted it all and started it up. idled fine then went to hell. so just to make sure nothing ripped i put my stocker back on. fired up fine with a small boost leak like always. so im gona get a retune sometime soon with the fmic on

srninjastar 04-07-2011 10:37 AM

my previous leak was at the throttle body because of a broken ic support bar. it saged to one side pulking the tmic at an angle causing the leak

baumgartenb 04-07-2011 10:49 AM

[quote=srninjastar;259285]my previous leak was at the throttle body because of a broken ic support bar. it saged to one side pulking the tmic at an angle causing the leak[/quote]

been there before...

srninjastar 04-07-2011 01:29 PM

so i got my tmic back on and all is well, sorta. but now my engine bay looks all sorts of rediculous. i have 2 charge pipes on either side of my engine bay going to this massive intercooler then it all leads up going no where and then a tmic just post up chilln. hahaha tooo funny.

man show 04-07-2011 11:14 PM

Fooler-cooler status :tease:


All times are GMT -5. The time now is 06:25 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.