just got my invidia dp... - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-23-2007, 07:02 PM Thread Starter
WRXtuners Member
 
Join Date: Sep 2006
Location: Pennsylvania
Posts: 285
Images: 14
Labukas19 is more helpful than not
just got my invidia dp...

well decided to go with an invidia catless dp... i was looking at it and the o2 sensor bung is on the top??? i dont have my car here so i cant see if there will be any fitment issues with my anti foulers... all the pics i see of this DP the bung is on the side... whats the deal anyoen know? and i dont have a camera to get pics...
Labukas19 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 08-24-2007, 06:54 AM
WRXtuners Member
 
W0R2X's Avatar
 
Join Date: Jul 2005
Location: Nevada
Posts: 152
Images: 11
W0R2X is an unknown
Send a message via AIM to W0R2X
i cant remember exactly where the bung is, but i dont think i had any issues with it. only issue im having right now is i think i need to adjust the bracket because i get that nasty knocking sound when i accelerate in reverse, or when im downshifting.
W0R2X is offline  
post #3 of 5 Old 08-24-2007, 11:24 AM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
the bung on the top is usally for aftermarket widband o2's. I have a Megan racing DP and it had a bung on the top and bottom

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
post #4 of 5 Old 08-24-2007, 12:36 PM
WRXtuners Member
 
lovemy07's Avatar
 
Join Date: Aug 2007
Location: Virginia
Posts: 24
Images: 3
lovemy07 is an unknown
we did one earlier and the O2 didn't fit. we just drilled and welded another bung onto the side and then plugged the top hole. We didn't realize this until we got to the shop and took the exhaust off. I went to put the sensor on and i was like "hey that's not right!!!"

Joe
lovemy07 is offline  
post #5 of 5 Old 08-25-2007, 05:32 PM
WRXtuners Member
 
Bmbsqd's Avatar
 
Join Date: Jul 2007
Location: New Jersey
Posts: 14
Bmbsqd is an unknown
Just put one on my 07 Rex last month with no problems.
Bmbsqd is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome