I blew her up last night at the track:( - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 Old 05-26-2007, 06:22 PM
WRXtuners Member
 
RedefinedWRX's Avatar
 
Join Date: Mar 2007
Location: Iowa
Posts: 137
Images: 5
RedefinedWRX is an unknown
Exclamation I blew her up last night at the track:(

READ CAREFULLY

Yep you heard it, I blew her up........ I made several passes down the track and I started to notice a smoking from out of the hood scoop. I was like what the heck is going on. I felt the back side of my Turbo XS intercooler and it was oiley and I could smell oil burning in the cab. I was like, oh damn something broke and broke bad. But the car was still running fine except I was not getting the kind of boost targets I expected all night long. Well there was a brake in the action after I got back to my pits because someone spilled oil all over the track, and it was synthetic. I was like damn , I hope that was not me. I get to my pit, feel the back side of my intercooler and it is oiley, the car is smoking and there is a hissing noise when the car is running. !Cry! I shut everything down and start to rip my intercooler off to see what is wrong. Well in the process I keep hering the hissing sound. I am like what the heck is that noise. My buddy who has been having bad luck with his 07 TR also comes over to take a look (he just rear ended a minivan to avoid hitting a mentaly handycaped person on a bike that came out of no where and crossed the road in front of both him and the van) Well anyway he hears the same noise. And I spot something, humm sence when are A/C lines flat. I was over joyed when I stuck my finger down there and the hissing stopped, there was oil on my finger, and metallic flakes. I was like, humm dont think the A/C will be working any time soon. Damn thing blew up on me. So I decited to remove the belt at the track, and inturn broke the tensioner for it. So I was like what the hell I might just remove all of it later this weekend, I never use it anyway. So I went back to making a few passes.

My fastest pass of the night was still a 13.5. No improvement with the new intercooler other than it took less boost to hit that number becasue my boost targets where set to 14psi in 1st gear, and than 18 from than on. And I was hitting 12psi in frist and like 14 from than on. Something was wrong. And the rain started in, so I was getting horible traction after they "dried" the track and took us down to running 1/8th mile only. So we went home.

On the way home I was hot rodding it a little and as I drove over the bridge I floored it in 3rd gear and it was like BOOM!!! Felt the car bog for a second, saw a huge flame shoot out of the exhaust and it was like driving a diffrent car. I was now hitting 18psi in every gear after 1st and holding there. I was really ripping up the road with the tune the car was set up for. What the heck happened? :eek: From than on the rest of the drive home was totally awesome. I have not driven the car yet today but I hope what ever happened last night keeps up. The extra boost is awesome, no check engine light flashing at me showing knock with my Utec, nothin. Just huge raw power. I can't wait to get back out to the track.

But what was that boom and a sudden increase in power? Waht would casue that? And I really never have had A/C in any car, it always brakes on me, should I just remove it? I riged up the A/C button to turn on my cooling fans for now, it is kinda neet.

07 WRX TR
- Alex
RedefinedWRX is offline  
Sponsored Links
Advertisement
 
#2 Old 05-26-2007, 06:44 PM
WRXtuners Member
 
Okeyd57's Avatar
 
Join Date: Apr 2006
Location: West Virginia
Posts: 145
Images: 4
Okeyd57 is an unknown
Is this an 07 ?

Okey's Black Mamba-06 STi-OBP- Cobb stage 2
Okeyd57 is offline  
#3 Old 05-26-2007, 06:54 PM
WRXtuners Member
 
RedefinedWRX's Avatar
 
Join Date: Mar 2007
Location: Iowa
Posts: 137
Images: 5
RedefinedWRX is an unknown
Yeah it only has 2600 miles on it. lol

07 WRX TR
- Alex
RedefinedWRX is offline  
#4 Old 05-26-2007, 07:12 PM
WRXtuners Member
 
Join Date: Sep 2006
Location: California
Posts: 231
RentForSale is an unknown
That car is as good as dead . It breaks ..... so you keep on driving it . It breaks more ..... you drive it like a hot rod . Go figure

-NICK-
RentForSale is offline  
#5 Old 05-26-2007, 07:55 PM
WRXtuners Member
 
Dogg777's Avatar
 
Join Date: May 2007
Location: California
Posts: 20
Images: 2
Dogg777 is an unknown
Quote:
Originally Posted by RedefinedWRX View Post
Yeah it only has 2600 miles on it. lol
2600 miles on it?? did you break it in at all? how many miles did you have on it when you first took it racing? when it is running now no knocks? rattles? anything like that?
Dogg777 is offline  
#6 Old 05-26-2007, 07:57 PM
WRXtuners Member
 
BithellWgn06's Avatar
 
Join Date: Oct 2006
Location: California
Posts: 355
BithellWgn06 is an unknown
What type of intercooler do you have on ther? I have a super large ebay and it is starting to frustrate me by all the noise it is making (squeaking) I am about to just suck it up and by an STI TMIC.

I am be curious as to what that noise (boom) was. What type of EM do you have?

BJJ for the win!
BithellWgn06 is offline  
#7 Old 05-26-2007, 08:11 PM
WRXtuners Member
 
mxboy15u's Avatar
 
Join Date: Oct 2005
Location: North Carolina
Posts: 1,470
mxboy15u is an unknown
Wow, very weird. Glad its working nicely now!
mxboy15u is offline  
#8 Old 05-26-2007, 09:17 PM
WRXtuners Member
 
RedefinedWRX's Avatar
 
Join Date: Mar 2007
Location: Iowa
Posts: 137
Images: 5
RedefinedWRX is an unknown
I am really surprized on how people don't read the posts here.

The I BLEW IT UP was a joke.

The only thing that broke was the Air Conditioning. The huge pop was just a common WRX Backfire. I saw the flame when I got on it, it was really no big deal. I broke the car in on regular oil untill 1500 miles, I raced it at about 2000 for the first time, but I switched over to Royal Purple oil on my first oil change. The car runs awesome. Just took it to dinner tonight, no problems at all, boosting better than ever before. What I think happened is there was something stuck holding the wastegate slightley open causing lower boost, now that the problem cleared itself the car runs way way better.

BTW it is the Turbo XS Intercooler (and it was not the intercooler that rubbed the hole, it was my IC sprayer braded steel line that did it) and I have a UTEC Delta EM. Never have seen any knock in the system and I always run 93 octane with a bottle of Lucas octane booster (which ups it 3 full octane or 30points to 96) Car runs harder than it ever has.

Only things that eneded up broken last night (A/C is completley empty) I removed the belt and in the process I broke the tensioner. no big deal. As far as the engine goes everything is 100% good as new. There are no new noises, just the little tick it had when I got it, which actually has quieted down some.

07 WRX TR
- Alex
RedefinedWRX is offline  
#9 Old 05-26-2007, 09:28 PM
WRXtuners Member
 
RedefinedWRX's Avatar
 
Join Date: Mar 2007
Location: Iowa
Posts: 137
Images: 5
RedefinedWRX is an unknown
Quote:
Originally Posted by Dogg777 View Post
2600 miles on it?? did you break it in at all? how many miles did you have on it when you first took it racing? when it is running now no knocks? rattles? anything like that?
You brake it in like you are giong to drive it, read the stickey on the newb forum. I also have raced for many years and totally agree with this statement. Car runs awesome, no problems at all. I BLEW IT UP was a joke refering to the AC being broken. As far as everyhting else goes car runs better than ever, I think there was crap in my wastgate holding it open.

07 WRX TR
- Alex
RedefinedWRX is offline  
#10 Old 05-27-2007, 11:29 AM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
Hope everything stays good for ya, you had me wondering, I thought you blew up the motor

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
#11 Old 05-27-2007, 12:12 PM
WRXtuners Member
 
RedefinedWRX's Avatar
 
Join Date: Mar 2007
Location: Iowa
Posts: 137
Images: 5
RedefinedWRX is an unknown
Yeah she is allright I just got to pull out the rest of the AC later tonight... who needs it anyway.

07 WRX TR
- Alex
RedefinedWRX is offline  
#12 Old 05-27-2007, 04:07 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Quote:
Originally Posted by RedefinedWRX View Post
Yeah she is allright I just got to pull out the rest of the AC later tonight... who needs it anyway.
+1 to that. Added weight and power robbing POS, lol.
newtothegame is offline  
#13 Old 05-28-2007, 06:10 AM
WRXtuners Member
 
RedefinedWRX's Avatar
 
Join Date: Mar 2007
Location: Iowa
Posts: 137
Images: 5
RedefinedWRX is an unknown
I got all of it out but the pump... damn thing is hard to remove, the bottom bolts are hidden back behind the cam cover and there is this bracket that wont budge. Oh well.... I got most of it out, and I hooked up my A/C switch just to kick on my fan when ever I want.

07 WRX TR
- Alex
RedefinedWRX is offline  
#14 Old 05-28-2007, 11:07 AM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
Quote:
Originally Posted by RedefinedWRX View Post
Yeah she is allright I just got to pull out the rest of the AC later tonight... who needs it anyway.
You should add one of those little roof scoops that you can open and close, for extra air to enter

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
#15 Old 05-28-2007, 11:53 AM
WRXtuners Member
 
Join Date: Sep 2006
Location: Nevada
Posts: 2,245
WRXKidid775 is more helpful than not
come to reno and then see if you need your AC haha.

you scared me for a second man glad to her shes ok.

Robby
02 rex is gone.
I defected to an evo :)
Evo is gone :(
Now I got nothing.
WRXKidid775 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On