Bad grinding sound when making a hard right! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old 09-07-2007, 07:45 PM Thread Starter
WRXtuners Member
 
07subie's Avatar
 
Join Date: Mar 2007
Location: California
Posts: 165
Images: 7
07subie is an unknown
Bad grinding sound when making a hard right!

--------------------------------------------------------------------------------

what up guys. I been trying to figure out what the grinding sound coming from my driver side wheel. I just got a cusco and whiteline front endlinks installed by project import. well at first thought it was that. But I dont think so. when I turn the wheel all the way to the right or left both the sway bar and links to hit anthing. I was also thinking it might be my front driver side brakes. Because that what sound like( the grinding sound i hear)but then I didnt think so because I dont have the brake applyed when I'm making a right turn. I have no idea what the grinding sound is! Anybody have this problem, anything will help. thanks


-Oscar
07subie is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 09-07-2007, 07:54 PM
WRXtuners Member
 
vagrantidol's Avatar
 
Join Date: Apr 2007
Location: California
Posts: 91
Images: 2
vagrantidol is an unknown
After looking at your profile your car is almost identical to mine xcept for the sways and links. 2 nights ago I had the same thing happen to my car. I know its not my brakes because I checked them 2 weeks ago and they still have like 1/4" of pad on each side. When it happened to me it sounded like I hit a rock in the road, but it didnt feel similar to hitting something. It hasnt happened to my since but I think it's just the strut hitting the bumpstop becuase you are completely compressing your uptravel very quickly.
vagrantidol is offline  
post #3 of 14 Old 09-07-2007, 07:58 PM Thread Starter
WRXtuners Member
 
07subie's Avatar
 
Join Date: Mar 2007
Location: California
Posts: 165
Images: 7
07subie is an unknown
Quote:
Originally Posted by vagrantidol View Post
After looking at your profile your car is almost identical to mine xcept for the sways and links. 2 nights ago I had the same thing happen to my car. I know its not my brakes because I checked them 2 weeks ago and they still have like 1/4" of pad on each side. When it happened to me it sounded like I hit a rock in the road, but it didnt feel similar to hitting something. It hasnt happened to my since but I think it's just the strut hitting the bumpstop becuase you are completely compressing your uptravel very quickly.
Car look bad ass. I dont it was that cause the grinding happens every time i make a right .
07subie is offline  
post #4 of 14 Old 09-07-2007, 08:04 PM
WRXtuners Member
 
vagrantidol's Avatar
 
Join Date: Apr 2007
Location: California
Posts: 91
Images: 2
vagrantidol is an unknown
i guess i read your question wrong, I have no grinding on my car. How many miles are on your car? Unless you drive hard your brakes should be in good working order, but I would definately put the car on stands, take off your wheel and check you brake pads first. If there is meat on them then i would start looking at your rim or struts. If its grinding it has to be from a moving metal part and the only one i can think of is your wheel and rotor. Your wheel bearing should be fine but if everything else looks good you might want to check those out and make sure they are packed with a copious amount of grease.
vagrantidol is offline  
post #5 of 14 Old 09-07-2007, 08:11 PM Thread Starter
WRXtuners Member
 
07subie's Avatar
 
Join Date: Mar 2007
Location: California
Posts: 165
Images: 7
07subie is an unknown
I only have 5200 miles on my car.
07subie is offline  
post #6 of 14 Old 09-07-2007, 09:45 PM
WRXtuners Member
 
vagrantidol's Avatar
 
Join Date: Apr 2007
Location: California
Posts: 91
Images: 2
vagrantidol is an unknown
then your brakes should be fine because i have almost 15k on my car and the pads are still beefy. I would take the rim off, and inspect everything. Look for signs of wear on the inside of your rim, your strut, and rotor assembly. If its not from one of those then I dont know, or the beer ive drank says i dont know, lol.
vagrantidol is offline  
post #7 of 14 Old 09-07-2007, 10:09 PM Thread Starter
WRXtuners Member
 
07subie's Avatar
 
Join Date: Mar 2007
Location: California
Posts: 165
Images: 7
07subie is an unknown
Quote:
Originally Posted by vagrantidol View Post
then your brakes should be fine because i have almost 15k on my car and the pads are still beefy. I would take the rim off, and inspect everything. Look for signs of wear on the inside of your rim, your strut, and rotor assembly. If its not from one of those then I dont know, or the beer ive drank says i dont know, lol.

dude that cf hood looks sick. I pushed back the dust plate seems that it went away but still not sure.
07subie is offline  
post #8 of 14 Old 09-07-2007, 10:25 PM
WRXtuners Member
 
Join Date: Aug 2006
Location: California
Posts: 158
king723 is an unknown
that was most likely your problem..ive done that before working on the brakes for subies..it happens easier on the outbacks to do that.
king723 is offline  
post #9 of 14 Old 09-08-2007, 05:00 AM
WRXtuners Member
 
vagrantidol's Avatar
 
Join Date: Apr 2007
Location: California
Posts: 91
Images: 2
vagrantidol is an unknown
yea, i tapped a chevy full size and its bumper just put a dent in only my hood thankfully, so i just bought a hood cause it was only $518 shipped and i couldnt stand that eyesore. Now that i got that i want a trunk and maybe a roof skin, but i dont know if it will look too much like a cop car and have them mess with me.
vagrantidol is offline  
post #10 of 14 Old 09-08-2007, 09:50 PM Thread Starter
WRXtuners Member
 
07subie's Avatar
 
Join Date: Mar 2007
Location: California
Posts: 165
Images: 7
07subie is an unknown
Quote:
Originally Posted by vagrantidol View Post
yea, i tapped a chevy full size and its bumper just put a dent in only my hood thankfully, so i just bought a hood cause it was only $518 shipped and i couldnt stand that eyesore. Now that i got that i want a trunk and maybe a roof skin, but i dont know if it will look too much like a cop car and have them mess with me.
That would be badass.I wish i could change the out side but saving for my down pipe and cobb access port.
07subie is offline  
post #11 of 14 Old 09-09-2007, 01:32 PM
WRXtuners Member
 
vagrantidol's Avatar
 
Join Date: Apr 2007
Location: California
Posts: 91
Images: 2
vagrantidol is an unknown
You can always get an xpt map and tactrix, thats the route i wanna go. For a titek catted dp $407, $79 for the cable, and $52 for the xpt map and you can be at stage 2, even cheaper if u want a catless dp. The accessport is nice, but i have no need for it really since I already own a laptop. that widget is expensive.
vagrantidol is offline  
post #12 of 14 Old 09-09-2007, 09:13 PM Thread Starter
WRXtuners Member
 
07subie's Avatar
 
Join Date: Mar 2007
Location: California
Posts: 165
Images: 7
07subie is an unknown
Yeah i know i can go that way but many people told it alost easier with the cobb. So you stock map gets saved to your laptop right?
07subie is offline  
post #13 of 14 Old 09-09-2007, 11:46 PM
WRXtuners Member
 
vagrantidol's Avatar
 
Join Date: Apr 2007
Location: California
Posts: 91
Images: 2
vagrantidol is an unknown
yea, i already have a stage 1 map ready, just waiting on my cable to come in so i can start playing. yea the stock map just dl's to the computer. I went this way because my goals are for a 20g turbo with supporting mods and xpt is coming out with a map for it, so i can get the power im looking for and have my EM not run me more than 3-400 altogether. If i went with the AP i would be $700 in the hole for stage 2, then more in the hole for tuning. I am the kinda person who likes to do things themselves if i can because i am always looking to gain knowledge in everything i do. I will let you know how it goes, if its impressive you can always drive here and i can hook you up with a reflash .
vagrantidol is offline  
post #14 of 14 Old 09-11-2007, 03:06 AM Thread Starter
WRXtuners Member
 
07subie's Avatar
 
Join Date: Mar 2007
Location: California
Posts: 165
Images: 7
07subie is an unknown
I know, i like do eveything my self but this is a big mod! I dont want to screw anything up. I have a lap top also and if all goes well with you reflash I would go down thier and get the reflash from you or you can just help me out. Let know how it goes.
07subie is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On