anyone with invidia v2 dp? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 09-15-2007, 03:25 PM Thread Starter
WRXtuners Member
 
wrxroberts's Avatar
 
Join Date: Aug 2006
Location: Maryland
Posts: 83
Images: 2
wrxroberts is an unknown
anyone with invidia v2 dp?

i just installed my full invidia turbo back with the v2 downpipe and the o2 sensor bung is mounted right below the driveshaft about a 1/4 inch.my 02 sensor is now bent off to the side from hitting the driveshaft over bumps i guess. it seems like really bad design from invidia, did anyone else run into this problem or is it just me? is there any way around this? thanks for any help
wrxroberts is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 09-15-2007, 06:11 PM
WRXpert
 
LiL Shoaf's Avatar
 
Join Date: Jun 2005
Location: Pennsylvania
Posts: 1,810
Images: 2
LiL Shoaf is more helpful than not
Send a message via AIM to LiL Shoaf Send a message via Yahoo to LiL Shoaf
Did you shoot a call or email to Invidia.. This doesn't sound like something one would expect from their products.. This might be a mistake..

02 WRX.. "It's fun when it runs.. Problem is that it hardly ever does..."
LiL Shoaf is offline  
post #3 of 8 Old 08-18-2008, 05:17 PM
WRXtuners Member
 
RXAK's Avatar
 
Join Date: Jul 2007
Location: Alaska
Posts: 29
Images: 3
RXAK is an unknown
I have this same problem. Did you figure out a fix? I'm thinking I need to weld in a new bung.

Thanks
RXAK is offline  
post #4 of 8 Old 08-22-2008, 02:53 PM
WRXtuners Member
 
RXAK's Avatar
 
Join Date: Jul 2007
Location: Alaska
Posts: 29
Images: 3
RXAK is an unknown
bump.....any help or experience with this problem?

thanks
RXAK is offline  
post #5 of 8 Old 08-22-2008, 03:59 PM
WRXtuners Member
 
zmanoside's Avatar
 
Join Date: Sep 2006
Location: North Carolina
Posts: 430
zmanoside is a helpful contributing member
I have this exact DP on my car with no problems whatsoever. Had it on my 06 wrx too and no problems.
Z

12.7 @ 109
zmanoside is offline  
post #6 of 8 Old 09-02-2008, 11:35 PM
WRXtuners Member
 
jrswrx69's Avatar
 
Join Date: Oct 2007
Location: Tennessee
Posts: 24
Images: 1
jrswrx69 is on thin ice
Send a message via Yahoo to jrswrx69
hey get a 90 dg bung will solve ## problem on some down pipes the bong aint far enough down or just wrong side
jrswrx69 is offline  
post #7 of 8 Old 09-03-2008, 10:33 AM
WRXtuners Member
 
96accord's Avatar
 
Join Date: May 2007
Location: Maryland
Posts: 125
96accord is an unknown
Send a message via AIM to 96accord Send a message via Yahoo to 96accord
07 WRX w/ same DP and no problems.
96accord is offline  
post #8 of 8 Old 09-05-2008, 11:56 AM
WRXtuners Member
 
THR3E11EVEN's Avatar
 
Join Date: Apr 2007
Location: Missouri
Posts: 130
Images: 6
THR3E11EVEN is an unknown
Send a message via AIM to THR3E11EVEN
No problems here either. 07 WRX. I love this DP! great design and flow.

Dub-R-X
THR3E11EVEN is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On