Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Non-Performance Tech (http://www.wrxtuners.com/forums/f73/)
-   -   Rallyarmor Mud Flap Install (http://www.wrxtuners.com/forums/f73/rallyarmor-mud-flap-install-27872/)

mfarnham 12-29-2009 01:56 PM

Rallyarmor Mud Flap Install
 
I just bought Rallyarmor mud flaps (02-07 ## Rally Mud Flaps Blue Logo) for my 2006 WRX. The instructions that came with them seem to only apply to the STi model. And their instuctional video is only for the STi as well. Does anyone know how to install the mud flaps on a '06 WRX? Thanks.

man show 12-29-2009 02:15 PM

I have a feeling the mud flaps would install the same way on an 02-07 WRX, 04-07 STi, and even the 02-07 Impreza 2.5 RS, for that matter. Have you noticed any major differences in the fender liner area between your WRX and the STi in the video?

mfarnham 12-29-2009 02:30 PM

[quote=man show;237703] Have you noticed any major differences in the fender liner area between your WRX and the STi in the video?[/quote]

Yes, the side skirt on the STi continues all the way to the wheel well. However, on my car the side skirt is separated from the wheel well by the bottom of the fender.

boostspike 12-29-2009 02:36 PM

if you've got a WRX TR which it looks like you do, you don't really have a "side skirt" its all metal, the sti has pieces you must get out of the way to install the mud flaps just skip the step about the side skirt and continue with the install.

man show 12-29-2009 07:40 PM

Cool, thanks for chiming in boostspike. I'd be curious to see a picture comparison between the two.

MurderedWRX 12-29-2009 11:11 PM

i just put a set on today and it was super easy idk if you figured it out but if u go to the the links i posted it will have video for ## car on how to install them !

[url=http://videos.hspn.com/?videoid=42]HSPN TV - HD Videos on Demand - Powered by HSPN Networks, LLC[/url]

if the link dont work just go to rallyarmor.com and in top right corner it will ask if your looking for install instructions and then choose ## car and go thru prompts it will show u everything u need to kno!!!! very easy very helpful!!!!

mfarnham 12-30-2009 09:44 AM

[quote=boostspike;237707]if you've got a WRX TR which it looks like you do, you don't really have a "side skirt" its all metal, the sti has pieces you must get out of the way to install the mud flaps just skip the step about the side skirt and continue with the install.[/quote]

Thanks boostspike. I'll give it another shot.

And I'll see what I can do about some pictures, man show.

PSD Operator 04-24-2010 07:50 AM

I think I'm going to return mine until Rallyarmor comes out with instructions that are legible, and made for the WRX, not the STI. Since they aren't the same body, the installation instructions are incorrect. Not exactly a top quality product if they don't even provide the proper instructions...

nagyhead 04-24-2010 09:08 AM

Come on people they are mud flaps, not that hard of an install. Shit I installed mine on a wagon where I had to drill new holes because the pre drilled holes didnt line up.

VisiX 04-25-2010 11:12 AM

[quote=PSD Operator;243903]I think I'm going to return mine until Rallyarmor comes out with instructions that are legible, and made for the WRX, not the STI. Since they aren't the same body, the installation instructions are incorrect. Not exactly a top quality product if they don't even provide the proper instructions...[/quote]

Keep the mudflaps and buy an STI, it's a win/win.

gunk007 04-25-2010 04:18 PM

[quote=VisiX;243917]Keep the mudflaps and buy an STI, it's a win/win.[/quote]

Great Idea!!!Thumbs Up

NotoriousToker 05-13-2010 10:38 PM

Wrong one?
 
Sounds to me like you just bought the one for the STI instead of the WRX. If you go to their site, the STI version appears to be different than the WRX version.

RcrsWetDream 05-13-2010 11:06 PM

[quote=PSD Operator;243903]I think I'm going to return mine until Rallyarmor comes out with instructions that are legible, and made for the WRX, not the STI. Since they aren't the same body, the installation instructions are incorrect. Not exactly a top quality product if they don't even provide the proper instructions...[/quote]

Took me a half hour...:confused:

NotoriousToker 06-04-2010 08:59 PM

Just installed these on my wrx
 
Ok so I just installed the flaps on my wrx. After seeing someone in ossining with a nice custom STI with the red UL flaps, I decided to go with red instead of black. Anyway, the instructions are available via video from rally armor's website. I found, however, that on the 2010, as compared with what they call "08+", the install was not the same. First of all, in the front, there was no need to pull the liner out, it came that way from the factory. So instead, I just removed the factory clips as shown in the video, pulled the skirt back a bit as shown, and then slipped the proper plastic clips on and screwed everything in as suggested. It is not as flush as I would like it, but its fine. The rear, was a whole other story though. Unlike on the "08+" instructions, there is actually a plastic liner on the rear of the wheel well that is not on the older version. That made sighting the hole almost impossible. So I screwed in the two screws on the side, then just went straight in wit hthe screw by drilling it right through. This was not easy, there was not nearly as tall of a "lip" of vertical metal hanging down as there is in the "08+" from the video. I just pushed hard with the drill, put it on a low speed, moved my hands well out of the way, and tried about 5 times until it went through. I did a sloppy job, don't do it this way. I did not have the right tools. I suggest first lining up that last top inner hole with the plastic liner, pushing it onto the metal lip with your hand so they stay in contact, and then boring a hole by hand first through the plastic in the right spot. Then do the metal, then screw it all in. Anyway, it took longer than I anticipated. I think it would be even easier to use the "clip method" as they call it in the video, but I wanted the security of having the flaps screwed in directly. If I did it all again, I'd use the clip method. I'll post some photos, but first, how do I assign a URL to my photo? It's just a file on my computer. ?? any help there? or is there just another way to add the photo that I don't see here... new to the forum. thanks.


All times are GMT -5. The time now is 07:01 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.