Greddy EGT gauge problem!! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-07-2005, 02:42 PM Thread Starter
WRXtuners Member
 
Noogin's Avatar
 
Join Date: Feb 2003
Location: Illinois
Posts: 124
Images: 4
Noogin is an unknown
Send a message via AIM to Noogin
Greddy EGT gauge problem!!

Well I got in my car yesterday and only half of the egt was lit up when i turned my headlights on. I expect it to be a bulb burnt out but not sure. Just wondering what the deal was before i start taking the gauge apart.
Thanks for your time
Noogin
Noogin is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-07-2005, 03:41 PM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
I thought those had LED's in them. If so, it will probably have to go back to Greddy to be replaced.
Cosmo is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome