cel o2 sensor code problems please help - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-27-2012, 02:30 AM Thread Starter
WRXtuners Member
 
Join Date: Jun 2012
Location: New York
Posts: 3
rosaom17 is an unknown
cel o2 sensor code problems please help

Ok i just recently purchased a 03 wrx and have the cel on. Now, the codes i am getting are p0130 and p0031. They told me that these codes indicate the front o2sensor. I immediately assumed it was bad so i bought the cheap universal bosch brand. I placed it on the car with the battery off and the dam cel is still on. (it went out for about 10 seconds than it came off. Now i again went to the store and told them this and they said i needed to run the car for about 0 to 500 miles. I went on a couple forums and they said as soon as you plug it in with the battery off it should remove the cel and not come back on. Can anyone please tell me what is wrong or what i need to do? i was going to take to subaru but i know they charge alot for any little problem. any type of help and comments will be greatly appreciated it. Thank You
rosaom17 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-27-2012, 06:52 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,980
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Well, are you getting BOTH codes after you replaced the sensor because it's not always just the sensor.

After a search I came up with this:

-Water or corrosion in the connector
-Loose terminals in the connector
-Wiring burnt on exhaust components
-Open or short in the wiring due to rubbing on engine components
-Holes in exhaust allowing unmetered oxygen into exhaust system
-Unmetered vacuum leak at the engine
-Bad o2 sensor
-Bad PCM

I'm going to go with a vac leak. Have you looked underneath from the downpipe back?

Are there any mods on the car?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome