Autometer CF Boost Gauge - Inaccuracy - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 05-13-2004, 04:04 PM Thread Starter
WRXtuners Member
 
Join Date: May 2004
Location: Washington
Posts: 3
DUBRX04 is an unknown
Thumbs down Autometer CF Boost Gauge - Inaccuracy

I have an Autometer Carbon Fiber Boost Gauge. A few weeks ago the needle fell off. So I sent it back to the company I got a new one. I just received the new gauge and swapped the new one but kept all existing hardware, wiring and vacuum line as the previous.

The new gauge reads different than the previous gauge. More Vacuum, less boost. I just figure that these gauges aren't accurate.

The only change I did was put a Borla Cat-back on. I wouldn't think that would change anything.

Any wisdom out there on this subject?

Thank you...
DUBRX04 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 05-13-2004, 04:06 PM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
Mine reads perfectly accurate. Of course, mine is the electronic one.

This does, however, prove my point:

Germans love David Hasselhoff!

Sorry. I meant:

All mechanical boost gauges are inaccurate!
Cosmo is offline  
post #3 of 5 Old 05-13-2004, 04:07 PM Thread Starter
WRXtuners Member
 
Join Date: May 2004
Location: Washington
Posts: 3
DUBRX04 is an unknown
How hard is it to hook up an elec. gauge? Is there anything on an install for elec. boost gauges.

Thanks!
DUBRX04 is offline  
post #4 of 5 Old 05-13-2004, 04:11 PM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
It's not very hard. You have to run the vacuum line to the MAP sensor, and then run a wiring harness to the gauge.
Cosmo is offline  
post #5 of 5 Old 05-14-2004, 07:17 AM
WRXtuners Member
 
Narrus's Avatar
 
Join Date: Aug 2003
Location: Michigan
Posts: 221
Narrus is an unknown
Send a message via Yahoo to Narrus
I've got the same gauge and haven't had any issues with it. But if the new one is different than the old, well, one was definitely wrong.
Narrus is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On