Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Non-Performance Tech (http://www.wrxtuners.com/forums/f73/)
-   -   Amp sub install.. (http://www.wrxtuners.com/forums/f73/amp-sub-install-32101/)

Duffie112 02-26-2012 07:02 PM

Amp sub install..
 
How are you guys getting all your wires to the trunk? Are you mounting amp in trunk with subs too? Thanks


Sent from my Autoguide iPad app

rex2002 02-26-2012 07:32 PM

i brought the cables through the rubber boot from the steering wheel shaft and ran it under the carpet along the center console and under the rear seats right to the truck. you could even do the same but run it along the drivers side kick panel. if you take that panel off you should be able to pull back the carpet back a little and tuck it in there

pzr2874 02-27-2012 06:45 AM

Put the amp under the seat (gets a little more air)

Don't ever attach the amp to the sub box.... Back in the day, that would be a neon sign on your car "STEAL ME".

Don't ask how I know this.... ha

Vew 02-27-2012 11:44 AM

I also put mine under the seat. However, if you do this, be sure to block off the heater vents. I used some scrap dynamat we had lying around the shop.

If you want it in the trunk, running it under the carpet long the console is probably the best way. Kick panel on the driver's side is the easier way.

AllExtinct 02-27-2012 06:23 PM

I have mine in my trunk screwed onto the back of my 12 box. I ran the RCA wire under the center console and let it show going under the back seat to the trunk. "was lazy"
I ran the power wire on the left side and grounded it in the trunk.

gunk007 02-27-2012 08:20 PM

I ran the power wire and Remote turn on along the driver side and the RCAs along the passanger side. I have my amp attached to my sub box. I also ran speaker wire up through the center of the car (for my speakers up front. Good luck!

Duffie112 02-27-2012 09:34 PM

Cool now I have some ideas when I do his Wednesday. What size subs you guys running? How they sound?


Sent from my Autoguide iPad app

gunk007 02-28-2012 08:06 AM

I have a 12" MTX hooked up to a mono amp (dont remeber the Wattage right now) . I really like it. I have had it for years and is starting to lose some of the punch but I like it.

man show 02-28-2012 10:54 AM

1 Attachment(s)
I used to have three JL Audio 12" subwoofers and a JL Audio 500 watt amp w/ a capacitor in a huge ass box that took up the majority of the trunk in my 1992 Explorer. When I sold that and got my 1996 Eclipse, I put two of the subwoofers in a spacesaver box with the same amp and capacitor and gave the other sub to my brother for his car. The whole setup was actually stolen once out of my Eclipse, but fortunately, insurance covered the loss and I got brand new equipment (the same stuff). When I sold the Eclipse, I sold the subs and amp to a friend of mine. While I enjoyed them, I think my subwoofer days are now over. It was fun setting off car alarms, but I'm sure I suffered a good bit of hearing loss because of them.

...and I actually have a picture of the Eclipse setup. Note the neon tube mounted above it - it flashed red and pulsed with the bass (somewhat embarrassing now, but I thought it was pretty awesome at the time).

AllExtinct 02-28-2012 08:21 PM

[quote=Duffie112;276283]Cool now I have some ideas when I do his Wednesday. What size subs you guys running? How they sound?


Sent from my Autoguide iPad app[/quote]

Im only running one Rockford P2 12" on a Audiobahn 800 bridged.
Sounds decent, I had 2 P2's hooked up but got sick of the lack of trunk space for tools and such.

While on the subject of subs.
Anyone ever try to make a custom box that mounts on the side of the trunk, was thinking about trying.

basco 02-28-2012 09:53 PM

subs make your car slow...therefore they are bad

mazzanic 02-28-2012 10:08 PM

I used to be in competitions for audio and no subs in wrx lol. I tried and almost rattled car apart with dynamat only running 350 watts rms to 1 ohm load which isnt much. If u like a little rattle then by all mean GFI and wire amp to seat and i actually went through fender on drivers side for power wire its was easilly accessible thrres. Plus our trunks arent flat n need custom box or itll look weird

turmic 02-28-2012 10:29 PM

[quote=man show;276302]I used to have three JL Audio 12" subwoofers and a JL Audio 500 watt amp w/ a capacitor in a huge ass box that took up the majority of the trunk in my 1992 Explorer. When I sold that and got my 1996 Eclipse, I put two of the subwoofers in a spacesaver box with the same amp and capacitor and gave the other sub to my brother for his car. The whole setup was actually stolen once out of my Eclipse, but fortunately, insurance covered the loss and I got brand new equipment (the same stuff). When I sold the Eclipse, I sold the subs and amp to a friend of mine. While I enjoyed them, I think my subwoofer days are now over. It was fun setting off car alarms, but I'm sure I suffered a good bit of hearing loss because of them.

...and I actually have a picture of the Eclipse setup. Note the neon tube mounted above it - it flashed red and pulsed with the bass (somewhat embarrassing now, but I thought it was pretty awesome at the time).[/quote]

That looks very familar. I had pretty much the same set-up that you had in your eclipse, but it was in a grand am and I had a eclipse head unit (a aftermarket head unit...not the mitsubishi head unit :p).


All times are GMT -5. The time now is 09:12 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.