2012 WRX OEM Audio Upgrade - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 09-14-2012, 04:19 PM
WRXtuners Member
 
KM-HI50's Avatar
 
Join Date: Jul 2012
Location: Hawaii
Posts: 25
Images: 4
KM-HI50 is an unknown
2012 WRX OEM Audio Upgrade

Like most of you, we found the 2012 OEM (Non Nav) head unit alittle to be desired.

Some of you spent lots of $$$ to upgrade to aftermarket units, amps, and speakers.

But on a limited budget and use of the same head unit, and factory speakers I found a quick upgrade to the sound.

I recently purchased 2 items which made this upgrade easy and fast with a minimal effort and skill level.

1) Purchased a Alpine KTP-445U 4-Channel Amplifier.

2) Wire harness with forward and reverse plugs. (Made by Mr. David Carter)
The web site to order one from is: ae64.com - Subaru Radio Wiring Harness - Order Form
I purchased the 20 pin combined "breakout" wire harness.

Simply cut the longer speaker wires in the middle somewhere and connect the amp in between, then plug into the head unit and factory 20 pin plug and your done.

Wire colors are exactly the same and made it super easy to wire together.

Now turn on your head unit and set the out put gain on the front and rear on the amp following the instructions but mostly to your listening ear.

Replace the head unit and AC vent then the front grill and your done.

I must say the volume level before the install was at 9-15 when driving, sometimes louder just to hear the radio or CD playing. NOW its at 5-9 and its very loud to me.

So if your looking for a easy, cheaper upgrade you can try this out!

Kurtis
2012 WRX Sedan "Satin White"
2011 Outback 2.5i CVT "Steel Metallic Silver" w/19mm RSB
KM-HI50 is offline  
Sponsored Links
Advertisement
 
#2 Old 12-02-2012, 11:23 AM
WRXtuners Member
 
Join Date: Dec 2012
Location: California
Posts: 3
calisubie is an unknown
So it got louder but what about the sound quality?
calisubie is offline  
#3 Old 12-02-2012, 04:58 PM
WRXtuners Member
 
BLAZE2099's Avatar
 
Join Date: Jan 2011
Location: Pennsylvania
Posts: 2,466
Images: 6
BLAZE2099 is known to be trustworthy and helpful BLAZE2099 is known to be trustworthy and helpful
Man that sounds like a good plan. But I also would like some insite to the bass/ treble and other quality aspects.

Randy-
2002 blaze WRX- sold:(
2004 Wrx-sold
2011 Wrx limited
99 Fozz- sold
Eagle eye crew
BLAZE2099 is offline  
#4 Old 12-02-2012, 05:40 PM
WRXtuners Member
 
KM-HI50's Avatar
 
Join Date: Jul 2012
Location: Hawaii
Posts: 25
Images: 4
KM-HI50 is an unknown
Hey Calisubie and Blaze2099 thanks for the questions.

Yes, it does boost the power output from the head unit to the speakers, and the sound is much improved with the amp.

To me it cleaned up the sound and make it cleaner.

I do recommend using the supplied ground loop isolators to further take out any hiss ( I did not and at lower volume you can hear some hiss in the background).

I suppose everything got better too me, but everyone has a different ear and expect a certain level of improvement with any sound equipment.

My only suggestion if you are not sure on pulling the trigger, is find a Alpine dealer that could demonstrate the amplifier to you with the lowest end stereo they have and speakers and judge for yourself if that is the route you'd take.

For me it was just a way to improve the sound and power from the factory unit and speakers and I'm satisfied with it.

Hope this helps a bit.

Kurtis
2012 WRX Sedan "Satin White"
2011 Outback 2.5i CVT "Steel Metallic Silver" w/19mm RSB
KM-HI50 is offline  
#5 Old 12-03-2012, 09:46 AM
Vew
Moderator
 
Vew's Avatar
 
Join Date: Feb 2004
Location: West Virginia
Posts: 3,444
Images: 10
Vew is more helpful than not
Send a message via AIM to Vew
Is it a hissing? Or is does it sound more like audible tachometer? Ground loop isolators are only temporary fixes - not the solution. If it's a constant hissing noise regardless of engine RPM, you probably just have the gain set too high.

The way we tuned our gain when I still worked in the install bay was to set the default setting on the headunit, crank up the volume to a couple notches from max, and play something with a wide range of sounds, everything from bass, mid, and treble. Then we only mess with the amp, while trying to listen to what sounds best. Takes a bit of experience to get it right, but since it's your car, your personal preference is good enough. I have a bit of trouble since I have some hearing loss from working in a factory and firearms.

Jon
"We live for a good time, not a long time."
RIP Colin McRae
Vew is offline  
#6 Old 12-05-2012, 10:57 PM
WRXtuners Member
 
KM-HI50's Avatar
 
Join Date: Jul 2012
Location: Hawaii
Posts: 25
Images: 4
KM-HI50 is an unknown
Hey Jon,

Thanks for the tip...the hissing is just that, not the audible tachometer like you mentioned.

I'm going to check the gain to see if that helps.

Kurtis
2012 WRX Sedan "Satin White"
2011 Outback 2.5i CVT "Steel Metallic Silver" w/19mm RSB
KM-HI50 is offline  
#7 Old 12-08-2012, 12:02 PM
WRXtuners Member
 
Join Date: Dec 2012
Location: California
Posts: 3
calisubie is an unknown
I pulled the trigger on the Alpine amp. Cant' find any bad reviews anywhere, only good ones. And I'll keep an eye on the hiss, that appears manageable.
calisubie is offline  
#8 Old 12-29-2012, 01:17 PM
WRXtuners Member
 
Join Date: Dec 2012
Location: California
Posts: 3
calisubie is an unknown
Just installed the Alpine KTP-445U 4-Channel Amplifier using the wire harness with forward and reverse plugs made by David Carter. Definite improvement for radio stations, and my Samsung Galaxy III bluetooth and iPod inputs, which sounded ok before, now sound even better.

Except for the RCA outs from the amp, I soldered and heat shrank my connections. For the RCA's, I bought some Kicker RCA to speaker adaptors (Kicker 09ZISL 2-channel speaker wire adapter (bare-wire connector to RCAs) at Crutchfield.com) so I could keep the amp RCA's intact. This also had the added benefit of providing just enough wire length to install the amp in a convenient location.

Locating the amp took a lot of time as I'm picky about keeping things tidy and looking professional. My ultimate solution was to use one side of industrial strength Velcro on the bottom of the amp and "fasten" the amp to the carpeting up above the passenger footwell. Additionally I used two pieces of the industrial Velcro under the carpet to attach it to the steel below the carpet. The Velcro is so strong it wants to peel off the amp before letting go of the carpet. Needless to say, the amp is not going anywhere. The nice things about this location are:

1. Plenty of air movement around amp.
2. Accessibility.
3. Looks clean, you wouldn't know it's there if you weren't looking.
4. Just the right distance to use all the amp's wiring, Kicker adaptors and Carter's harness, without any extra wiring needed.

Here are some photos of the amp tucked into it's new home.
Attached Images
   

Last edited by calisubie; 12-29-2012 at 03:40 PM. Reason: typos
calisubie is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On