WRX won't run after turbo/injector install - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 07-25-2013, 04:07 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2013
Location: South Dakota
Posts: 3
snowth1ef is an unknown
WRX won't run after turbo/injector install

Hi all, I'm new to this forumn site, but I've been over at NASIOC for awhile, just having a huge problem with my car and trying to get it solved.

Car: '06 WRX TR
Mods: Open Bellmouth DP, SPT Catback, Cobb Stage 2 Prior to this
New Mods: VF30 Turbo, Originally used DW750 injectors(Thought they were the issue, now Installed Brand new Bosch EV14 1000cc injectors. )

Here is a video of how my car runs: 2006 Subaru WRX will not run after injector install - YouTube

installed the new id1000 injectors, scaled them correctly and input the correct latency, and it runs like this, idle cycles from barely running to 2000ish and it cycles from rich to lean repeatedly. does this for about a minute and then the idle drops so low it dies. if you give it a little bit of throttle you can somewhat keep it running, anything more than about 20% throttle or so and it sputters out and dies. car has no power, is not drivable, and I cannot get it into boost, the second I hit boost it is like i hit fuel cut. Help? !Cry!

Only things that I could thing of are a vacuum leak or ignition issue? which I havent been able to find, just to make sure I have everything hooked up right, would anyone happen to have a vacuum diagram of the stock BPV and the Turbo/IWG setup? I'm mostly sure they are hooked up right but I want to be sure.
snowth1ef is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 07-25-2013, 04:09 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2013
Location: South Dakota
Posts: 3
snowth1ef is an unknown
Also, I installed new spark plugs, don't know if that makes a difference. They were iridium's.
snowth1ef is offline  
post #3 of 7 Old 07-25-2013, 07:17 PM
WRXtuners Member
 
psinuse's Avatar
 
Join Date: Nov 2004
Location: Ohio
Posts: 3,110
psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to
Latency values are what i'd be looking at not to mention 1000cc are a bit overkill.

Resident Grumpy Old Man(Keith)
03 SRP 2.34L
08' LGT Gears...
psinuse is offline  
post #4 of 7 Old 07-25-2013, 07:55 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,979
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
So it did this with the 750's as well?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #5 of 7 Old 07-25-2013, 10:16 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2013
Location: South Dakota
Posts: 3
snowth1ef is an unknown
1000cc isn't quite overkill because I plan on running an e85 tune, so I will need the extra fuel. and yes it did it with the 750s also
snowth1ef is offline  
post #6 of 7 Old 07-26-2013, 06:14 AM
WRXtuners Member
 
psinuse's Avatar
 
Join Date: Nov 2004
Location: Ohio
Posts: 3,110
psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to
Are you getting any kind of CEL at all?

Resident Grumpy Old Man(Keith)
03 SRP 2.34L
08' LGT Gears...
psinuse is offline  
post #7 of 7 Old 07-26-2013, 08:53 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,979
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
And are you opensourcing it?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome