Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   WRX new intercooler,now engine will not run (http://www.wrxtuners.com/forums/f72/wrx-new-intercooler-now-engine-will-not-run-29257/)

dennis49 08-07-2010 07:08 PM

WRX new intercooler,now engine will not run
 
I had an intercooler fitted to the front and I think the people did not know what they were doing, I think the vacuum or air pipes have been fitted in wrong position, after cleaning spark plugs engine runs very bad poor fuel is being pumped in alot of blck smoke and will only rev to 2000 rpm and runs a tank of fuel in 60 kilometers., once stopped will not start and plugs have to be replaced.

LewdWRX 08-14-2010 10:00 PM

So you didn't have it tuned after the installation? If not you should NOT START the car again until you get it to a shop.

Drain the oil and replace the oil and filter.

Replace the spark plugs.

Have the tuner load a base map and tune from there.

Do you have a CEL?

LewdWRX 08-26-2010 08:27 AM

Dennis49, what is the status of your ride now? Did you get this corrected? What did you do to correct it?


All times are GMT -5. The time now is 04:53 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome