Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   Wrx fluttering idle/car stalls when not under throttle (http://www.wrxtuners.com/forums/f72/wrx-fluttering-idle-car-stalls-when-not-under-throttle-33217/)

NickMar 10-31-2012 05:36 PM

Wrx fluttering idle/car stalls when not under throttle
 
I'm sure this topic has been covered before so I apologize in advance for bringing it up.
I have a 2007 wrx 18000 miles I have all the mods listed on my profile but just recently when starting the car the rpms would shoot high around 2grand then down to about 400 and then find a balance around 1500. When I rev it up at all after I pull my foot off the pedal it shoots down to about 100 rpms and it sounds like its about to stall then it catches itself and goes back to 1500.
Once I'm on the road when I am coming to a stop in neutral or in gear the idle flutters anywhere between 2 grand to 300. Every once in awhile while I'm driving if I release the throttle the car will stall this isn't every time but close. Please help. Thank you

BLAZE2099 10-31-2012 06:35 PM

Who tuned you, how soon after your last tune did this start happening?

NickMar 10-31-2012 06:54 PM

[quote=BLAZE2099;287406]Who tuned you, how soon after your last tune did this start happening?[/quote]

Open source tune. And it's been a couple months since the tune. The guy I bought it from tuned it not myself. But it just started happening about two days ago

pzr2874 11-01-2012 05:52 AM

No CEL codes?

NickMar 11-01-2012 12:36 PM

[quote=pzr2874;287414]No CEL codes?[/quote]

No codes at all. Today when I was driving to work the air bag light did come on after the car almost stalled again and the light stayed on until I turne the car completely off an then back on

Okeyd57 05-14-2013 07:14 PM

[quote=NickMar;287404]I'm sure this topic has been covered before so I apologize in advance for bringing it up.
I have a 2007 wrx 18000 miles I have all the mods listed on my profile but just recently when starting the car the rpms would shoot high around 2grand then down to about 400 and then find a balance around 1500. When I rev it up at all after I pull my foot off the pedal it shoots down to about 100 rpms and it sounds like its about to stall then it catches itself and goes back to 1500.
Once I'm on the road when I am coming to a stop in neutral or in gear the idle flutters anywhere between 2 grand to 300. Every once in awhile while I'm driving if I release the throttle the car will stall this isn't every time but close. Please help. Thank you[/quote]





When, and if, you ever figure this problem out, please let me know. I've got the very same problem with my 06 STi, with 23,000 miles total. My mods should be on my profile, also. I have a pro tune on my accessport. About 2 months ago, it gave out completely. I had it towed to my Subaru dealer. They said it was the fuel pump, so I ordered a new Walbro. It ran great for about 2 weeks, and the code was back (?????) along with the up and down idle. It was still better than it was, but it wasn't right.

I went back last week to get a state inspection sticker, and I had the mechanic clean my throttle body up. It helped a little more, but it's still not perfect, like it was.

I've met women that weren't as frustrating as this problem has been for me to figure out ! Good Luck to ya, and if I hear anything, I'll pm you. Okey

jimbo058 05-21-2013 12:52 PM

Try replacing the Throttle Position Sensor (TPS).

tondelayo 05-26-2013 06:51 PM

Vacuum leaks anywhere?
 
[quote=NickMar;287404]I'm sure this topic has been covered before so I apologize in advance for bringing it up.
I have a 2007 wrx 18000 miles I have all the mods listed on my profile but just recently when starting the car the rpms would shoot high around 2grand then down to about 400 and then find a balance around 1500. When I rev it up at all after I pull my foot off the pedal it shoots down to about 100 rpms and it sounds like its about to stall then it catches itself and goes back to 1500.
Once I'm on the road when I am coming to a stop in neutral or in gear the idle flutters anywhere between 2 grand to 300. Every once in awhile while I'm driving if I release the throttle the car will stall this isn't every time but close. Please help. Thank you[/quote]

Have you checked for vacuum leaks anywhere and everywhere, including the brake booster?


All times are GMT -5. The time now is 05:27 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.