Wipers getting damage from washer spray? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 05-04-2003, 08:18 PM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
Wipers getting damage from washer spray?

I would like to know if anyone else has had this problem. It seems the washer spray is wearing away the black finish on the metal wiper arms. If anyone knows what can be done or if they have taken it to Subaru and they fiexed it please let me know. I think I am going to take it to the dealer. I have only had the car since Oct. It's a 2003. It's not like I put something in the washer fluid. It's just the normal blue stuff.
WizzD is offline  
Sponsored Links
Advertisement
 
#2 Old 05-04-2003, 08:19 PM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
I have more pics.
WizzD is offline  
#3 Old 05-04-2003, 08:20 PM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
another
WizzD is offline  
#4 Old 05-04-2003, 08:21 PM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
And on this one you can see it is right where the stream of washer fluid goes.
WizzD is offline  
#5 Old 05-07-2003, 10:43 AM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
I went to the dealer yesterday. They will replace both of them. They say they haven't seen it before. The new parts should be in tomorrow and I'll let you all know how it turns out.
WizzD is offline  
#6 Old 05-13-2003, 08:45 AM
WRXtuners Member
 
WizzD's Avatar
 
Join Date: Oct 2002
Location: New Jersey
Posts: 144
Images: 6
WizzD is an unknown
Send a message via AIM to WizzD
Well I just got them replaced yesterday. The guy again said he hadn't seen it before but you have to wonder if that's really true or not. I'd like to know if this happened to anyone else in such a short period of time. Nobody there said anything about any of my mods either. Not a comment or a question.
WizzD is offline  
#7 Old 05-13-2003, 09:13 AM
WRXtuners Member
 
Join Date: Oct 2002
Location: B-more, MD
Posts: 85
DJSpaghetto69 is an unknown
Send a message via AIM to DJSpaghetto69
I have seen that before. For a VW factory service, we filled the washer resivior with thier own washer fluid. This stuff was more of a paint remover. It would start off with the same corrosive look as those, then move onto pealing the paint off.... It was kinda cool! I have never seen a Windshield washer fluid with a warning that it peals pain before. Go figure. But, it must be the type of fluid you are using. Get it out of the resivior, clean it good, then fill it with something generic.

JDMness... Yum!
DJSpaghetto69 is offline  
#8 Old 05-16-2003, 01:40 PM
WRXtuners Member
 
Join Date: Apr 2003
Location: Arcadia CA
Posts: 19
manato is an unknown
what? isn't that too dangerous then? whats gona happen to paint? my sprayer is soo powerful that it sprays from my front to the back window!!! >< whats gona happen to my paint
manato is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On