whining noise...loss of power... - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-27-2010, 09:25 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2010
Location: New York
Posts: 21
WRXIE is an unknown
whining noise...loss of power...

today i started hearing this loud whining noise only when i hit the gas.......i have a 2004 wrx wagon(turbo back catless exhaust, and k&n typhoon intake thoes are all the mods i have) now i def have a loss of power and the whining gets loud when i try to drill it..... i was thinking boost leak maybe or exhaust leak, fuel pump but idk..... also it makes the noise when the car is in neutral(so im not to sure about the boost leak).....if you need any other info hit me up asap im dropppin it off at my mechanic tomm morning but i would likke to get a heads up on what he should be looking for........
WRXIE is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-25-2011, 09:38 PM
WRXtuners Member
 
Join Date: Jan 2011
Location: Georgia
Posts: 1
Dcgotsstyle is an unknown
Hey man, I also have an 04 wrx wagon and mine is doing the same thing. I am taking it in to the shop tomorrow. What ended up being the problem? and was it terribly expensive? Thanks
Dcgotsstyle is offline  
post #3 of 3 Old 01-27-2011, 11:49 AM
WRXtuners Member
 
Subbie's Avatar
 
Join Date: Dec 2010
Location: Texas
Posts: 254
Subbie is more helpful than not
Garage
It sounds like a boost leak.

"Dustin"
- 08' WRX Premium - SOLD
- 08' Yamaha R1 - Top Speed seen is 204 - SOLD
Subbie is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On