Whats Wrong??? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 03-01-2008, 12:03 AM
WRXtuners Member
 
Join Date: Oct 2007
Location: Kentucky
Posts: 77
SUBY777 is on thin ice
Unhappy Whats Wrong???

install of headers uppipe downpipe and turbo inlet. i guess i didnt notice when i left the shop that there was a puddle of sometype of oil under the turbo inlet. i got home admiring the work when i noticed it. i thought it was not cleaned up from the install so i wiped it clean. i drove to the carwash and the puddle was back and dripping close to the crank pulley. what is that oil??? is it power steering fluid or engine oil?????? im worried now.
SUBY777 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-01-2008, 09:26 AM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
if its red (ATF) then its power sterring fluid. if its oil, you most likely have a leaking head gasket. at my previous job I saw about 3-4 with the same symptoms and we replaced the head gaskets and the problem was solved.

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
#3 Old 03-02-2008, 11:10 PM
WRXtuners Member
 
Join Date: Oct 2007
Location: Kentucky
Posts: 77
SUBY777 is on thin ice
Talking Thanks

went to the track ran a 8.85 with no tune (running lean) and my clutch hating me(slipping).
ran the 4th race and my clutch gave out. still happy about the time though!! now i need fuel system upgrade clutch and tune. thanks for the recommendation about the gasket. ill get that changed asap.
SUBY777 is offline  
#4 Old 03-03-2008, 10:22 AM
WRXtuners Member
 
Join Date: May 2007
Location: Connecticut
Posts: 116
Jcarv20 is an unknown
You ran an 8.85 in what?
Jcarv20 is offline  
#5 Old 03-10-2008, 09:15 AM
WRXtuners Member
 
Join Date: Oct 2007
Location: Kentucky
Posts: 77
SUBY777 is on thin ice
in a 1/8th @76.7

my clutch was slipping. i could feel it not pulling.i really need a tune and clutch.
SUBY777 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On