Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   What could cause loss of power to dash display, radio, heater controls ? (http://www.wrxtuners.com/forums/f72/what-could-cause-loss-power-dash-display-radio-heater-controls-33363/)

jimbo058 12-11-2012 02:29 PM

What could cause loss of power to dash display, radio, heater controls ?
 
Ok, I was heading home from work a few days ago and noticed that the dash display in my '09 REX (that shows temp/mileage/time) was out. In further checking, I discovered the radio and heater/ventilation controls were out as well. wtf. The car seemed to drive ok, so I proceeded across town.

I then pulled every fuse out of the fuse box, and inspected it for being blown and re-seated. None were blown. Tried to start the car, and after about 5 seconds of cranking, it finally started. I soon noticed that it was not boosting, and seemed to be in a limp-home mode. I reset the ECU and then reflashed. Everything is now working ok for the last few days.

My concern is that if it had been real cold or dark that day, that I would not have had defrost or lights, and would have been totally screwed.

Any idea what may have caused this issue? Some other people have suggested a bad ignition switch. The only clue I have to relate to that is when I was going to reflash with my AP, it asked several times to "TURN IGNITION KEY OFF AND THEN BACK ON" before it would allow me to proceed to do the reflash.

ProblematicWRX 04-29-2013 02:04 PM

Hey I just got this identical problem on my way home from work today and was wondering what the outcome ended up being?

boo-key bear 04-30-2013 09:12 AM

Not sure on this but just gonna throw it out there. Maybe a relay going bad????

jimbo058 05-03-2013 12:30 PM

The problem has not re-occurred. It must have been a loose relay or some contacts in the ignition switch that did not line up right.

foxhound720 05-14-2013 08:55 PM

I am experiencing similar issues currently but only difference is that my car died and can't restart. I jumped it and it started but wouldn't re start. I'm wondering if its the ignition switch, alternator or sbf fuses


All times are GMT -5. The time now is 02:47 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.