Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   Weird sound from turbo (http://www.wrxtuners.com/forums/f72/weird-sound-turbo-33776/)

RickyTurbo11 03-26-2013 02:14 PM

Weird sound from turbo
 
So in the past couple weeks I've noticed a loud screeching noise when my turbo spools rite before I shift. Can't really tell if its when I engage my clutch or its rite before it. I don't remember it before. Not sure what it is. I have a GFB bov but I have it set to fully recirculating so I'm not sure if its just that or an issue with a bearing when I gas it and the turbo spools. Anyone ever notice this or have an idea of what it may be?

man show 03-26-2013 08:49 PM

Without actually hearing the sound, it's hard to diagnose what the problem might be.

Based on your description though, your valve might be leaking just a little bit when the boost builds - perhaps you could try tightening the valve just a little bit?

As easy as a bpv is to swap, you might want to also consider swapping the GFB unit for a stock unit (if you still have it) and see if that solves your problem.

the RIOT act 03-27-2013 06:46 AM

Those GFB's are always on the boards with leak problems, so I'd def start there. I'd say grab a new gasket for it, and also use a sealer for extra protection around the outside of the gasket. That's what I did with my Forge BPV and I've had no problems. It definitely sounds more like a valve leak though rather than a turbo problem.


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

the RIOT act 03-27-2013 06:48 AM

Btw I really need to hear that exhaust setup ASAP lol! You should be coming on the Spring Mountain Run I'm hosting next month anyways...you're not far from the starting point in Auburn, MA. Hope to see you there!


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]

RickyTurbo11 03-27-2013 08:44 AM

Thanks guys. The more I hear it the more I think that's what it is. Ill try a new seal and the sealer and if that doesn't help ill put my bpv back on and see if that's it. And ill get a video of my exhaust later today and post it. It sounds ridiculous. So mean. And I'd be willin to drive to that meet with some of my boys who own Rex's too.

the RIOT act 03-27-2013 10:09 AM

You def should roll with us man. There's about 17 going so far. I have it posted in the regional forum of NASIOC as well as FB too. Hoping it turns into something huge! Bring as many as possible. Back on topic though, just make sure you don't leave the stock BPV on as your current boost level has to be around 18psi and that's where our stockers start failing. A new gasket and some high temp RTV sealant should set you straight though.


[color=gray]Sent from [url=http://www.autoguide.com/mobile]AutoGuide.com App[/url][/color]


All times are GMT -5. The time now is 06:55 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.