Wastegate CEL??? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 01-30-2005, 09:32 AM Thread Starter
WRXtuners Member
 
Join Date: Nov 2004
Location: New Hampshire
Posts: 46
Images: 3
sik04wrx is an unknown
Wastegate CEL???

sound familiar to anyone?? i was on the highway last nite in 4th gear and i got on it the car pulled for a little bit but out of the blue it like cut out then came right back it put the engine lite on i checked it at work and it said wastegate somthin any ideas??
sik04wrx is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 02-04-2005, 08:52 AM
WRXtuners Member
 
leewmlds's Avatar
 
Join Date: Oct 2004
Location: Virginia
Posts: 100
Images: 16
leewmlds is an unknown
i had the same problem. it was bad gas
leewmlds is offline  
post #3 of 12 Old 02-04-2005, 09:40 AM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
You know, that's becoming a more and more common problem. I've never had it, but I know three people locally who have. Subaru replaced the wastegate on two of them. Do you remember the actual CEL code #?
Cosmo is offline  
post #4 of 12 Old 02-04-2005, 02:59 PM Thread Starter
WRXtuners Member
 
Join Date: Nov 2004
Location: New Hampshire
Posts: 46
Images: 3
sik04wrx is an unknown
The exact code it gave me was P0244 Turbo Wastegate A SOL Range/Perf i have now clue what that means???
sik04wrx is offline  
post #5 of 12 Old 02-05-2005, 01:48 PM
WRXtuners Member
 
Join Date: Feb 2005
Location: North Carolina
Posts: 11
Images: 2
uc6starz is an unknown
Send a message via AIM to uc6starz
The same thing happen to me but only if I set my boost controller to high. I have read in an article that the ECU will trip the fuel pump if the manifold pressure gets to high.
uc6starz is offline  
post #6 of 12 Old 02-07-2005, 08:19 PM Thread Starter
WRXtuners Member
 
Join Date: Nov 2004
Location: New Hampshire
Posts: 46
Images: 3
sik04wrx is an unknown
Another thing that i was thinking is the vacuum hoses that go to the wastegate 1 of them is supposed to have a resistor in it of some kind i removed my MBC and i dont know if i put the right hose back in could that set off the CEL?? Im gonna get the hoses from Subaru just to be safe anyways but i tried to get them...i guess they come in like a group that go around the wastegate but i CANNOT get them to send me the right part...so what im sayin is if anyone has had to order these hoses b4 do u remember the part # if u do it would save me ALOT of aggravation...THANKS!!
sik04wrx is offline  
post #7 of 12 Old 02-21-2005, 10:09 PM
WRXtuners Member
 
Join Date: Apr 2004
Location: Pennsylvania
Posts: 352
hondaeater is more helpful than not
you've hit fuel cut because of too much boost. It cuts at the injectors, not the fuel pump.

no idea what the # is, sorry.
hondaeater is offline  
post #8 of 12 Old 02-24-2005, 06:29 PM Thread Starter
WRXtuners Member
 
Join Date: Nov 2004
Location: New Hampshire
Posts: 46
Images: 3
sik04wrx is an unknown
what would make it hit fuel cut i mean i dont have any boost control or anything all i have is a BOV and exhaust and thats it??
sik04wrx is offline  
post #9 of 12 Old 02-25-2005, 08:30 AM
WRXtuners Member
 
Join Date: Apr 2004
Location: Pennsylvania
Posts: 352
hondaeater is more helpful than not
if you removed that restrictor you're running too boost. You can even hit it WITH the restrictor. I've hit it, i have no BC's and off the shelf EM from cobb, vf34 map. It's easier to overboost your car in 4th and 5th, your turbo and engine will like you more if you give it smooth acceleration, not floor it and over boost.

maybe go to the dealer and point out the hose you want. It's only one host that has the pill in it, it's the hose from the "t" line to the compressor nipple.
hondaeater is offline  
post #10 of 12 Old 02-25-2005, 08:57 AM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
If you don't have the restrictor in the hose, you usually have the opposite problem - not enough boost. That restrictor keeps pressure from reaching the boost control solenoid, and makes it open later. Without that restrictor it opens pretty quickly. However, I guess if you had it in there backwards (on the wrong side of the T), it could cause overboosting.
Cosmo is offline  
post #11 of 12 Old 02-25-2005, 07:36 PM
WRXtuners Member
 
Join Date: Apr 2004
Location: Pennsylvania
Posts: 352
hondaeater is more helpful than not
oh yea. no pill=wastegate boost, and if you flip the hoses it'll still be wastegate boost, ask me how I know.

You also could have tore one of the lines, allowing pressure to be released and not seen by the FBC.

The compressor hose could also be pinched shut. Examine the hoses, i bet you'll see which one is damaged.
hondaeater is offline  
post #12 of 12 Old 03-12-2005, 12:08 PM
WRXtuners Member
 
berg8992's Avatar
 
Join Date: Dec 2004
Location: Ohio
Posts: 38
Images: 7
berg8992 is an unknown
I have had something similar happen. I had a boost control on and my engine cut out due to overboost. So I took the manual boost control off and now my car is only giving a max boost of 9 in all gears. Is this a wastegate problem? Will Subaru replace my wastegate even after I modified the boost amount?
berg8992 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome