vf34 boost creep - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 Old 03-15-2004, 07:50 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2003
Location: Virginia
Posts: 54
Images: 3
delswrx is an unknown
vf34 boost creep

Is anyone else having problems with boost creep running the vf34 turbo? Even with the compressor outlet connected straight to the wastegate i still creep to 20psi. I should a replacement actuator soon but i just wanted to know if anyone else was having problems or had any ideas. I have the turboxs up and invidia downpipe.
delswrx is offline  
Sponsored Links
Advertisement
 
post #2 of 19 Old 03-15-2004, 09:37 PM
WRXtuners Member
 
fc735's Avatar
 
Join Date: Apr 2003
Posts: 1,890
Images: 12
fc735 is more helpful than not
Send a message via AIM to fc735
wow...20psi off of a 9psi spring? something doesnt sound right.....

do the actuator first, i believe that is the issue...
fc735 is offline  
post #3 of 19 Old 03-15-2004, 09:53 PM
WRXtuners Member
 
Join Date: Jun 2003
Location: DeleonSprings,FL
Posts: 45
gverdinez is an unknown
where are you going to buy the actuator? I need one for my VF30 but I can seem to find a place that sales them. Does anybody know of a webb site that sales the VF30 actuator?
gverdinez is offline  
post #4 of 19 Old 03-15-2004, 10:08 PM
WRXtuners Member
 
fc735's Avatar
 
Join Date: Apr 2003
Posts: 1,890
Images: 12
fc735 is more helpful than not
Send a message via AIM to fc735
i get mine from ATP turbo....however, they are universal ones...and take some fabricating to work.


my bet is the diaphraghm in the actuator has a hole in it....there are ways to test them, it involves a pressure pump and a hose. real simple system...not a lot to go wrong.
fc735 is offline  
post #5 of 19 Old 03-16-2004, 08:37 AM
WRXtuners Member
 
Cosmo's Avatar
 
Join Date: Dec 2002
Location: Virginia
Posts: 4,591
Images: 15
Cosmo is known to be trustworthy and helpful Cosmo is known to be trustworthy and helpful
Send a message via AIM to Cosmo
I haven't had that problem with mine. Mine is pretty consistent. However, I have heard of people switching to a dual inlet wastegate actuator and they claim that fixes the problem.
Cosmo is offline  
post #6 of 19 Old 03-16-2004, 03:09 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2003
Location: Virginia
Posts: 54
Images: 3
delswrx is an unknown
I tested it with an air pump and gauge, at about 12psi it starts to open up, and then 15 a little more but doesnt open up all the way until 20psi, it doesnt leak air at all, its almost as if i got an actuator with the wrong spring in it. I tested my the one on my stock turbo at that ones fully open at about 12psi.
delswrx is offline  
post #7 of 19 Old 03-17-2004, 01:13 PM
WRXtuners Member
 
fc735's Avatar
 
Join Date: Apr 2003
Posts: 1,890
Images: 12
fc735 is more helpful than not
Send a message via AIM to fc735
you could increase the length of the actuator rod....that will allow the gate to be partly open, lowering boost.

giving ideas here...
fc735 is offline  
post #8 of 19 Old 03-20-2004, 10:49 AM Thread Starter
WRXtuners Member
 
Join Date: Feb 2003
Location: Virginia
Posts: 54
Images: 3
delswrx is an unknown
i looked and the actuator rod on the vf34 isnt adjustable, i'm thinking about just getting another turbo instead of trying to make this one work.
delswrx is offline  
post #9 of 19 Old 03-22-2004, 11:03 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2003
Location: Virginia
Posts: 54
Images: 3
delswrx is an unknown
I went ahead and ordered a forced performance 18g, i believe the exhaust housing comes ported to help with boost creep. I also scheduled a custom tune with turbo xs. I'll let you guys know how it works out. Thanks for he ideas.
delswrx is offline  
post #10 of 19 Old 03-23-2004, 09:01 PM
WRXtuners Member
 
Kobiyashi's Avatar
 
Join Date: Feb 2003
Location: North Carolina
Posts: 578
Images: 2
Kobiyashi is more helpful than not
Quote:
Originally posted by delswrx
I went ahead and ordered a forced performance 18g, i believe the exhaust housing comes ported to help with boost creep. I also scheduled a custom tune with turbo xs. I'll let you guys know how it works out. Thanks for he ideas.
welcome to my world =P You'll like it... A LOT. With that turbo though, if you are tracking it; I would invest in water injection (its love).

-kobi
Kobiyashi is offline  
post #11 of 19 Old 03-23-2004, 09:08 PM
WRXtuners Member
 
fc735's Avatar
 
Join Date: Apr 2003
Posts: 1,890
Images: 12
fc735 is more helpful than not
Send a message via AIM to fc735
18g is for ####sies



real men run a T61

this isnt me...its a guy on NASIOc (jared Nelson) that got his running now....

http://www.utracing.com/jared/100_0603_small.jpg

* for some reason.....that site dont like remote linking....klic teh leenk!

Last edited by fc735; 03-23-2004 at 09:17 PM.
fc735 is offline  
post #12 of 19 Old 03-23-2004, 09:19 PM
WRXtuners Member
 
fc735's Avatar
 
Join Date: Apr 2003
Posts: 1,890
Images: 12
fc735 is more helpful than not
Send a message via AIM to fc735
for the real lazy...
Attached Images
 
fc735 is offline  
post #13 of 19 Old 03-23-2004, 11:15 PM
WRXtuners Member
 
Tut4u2's Avatar
 
Join Date: Jun 2003
Location: Virginia
Posts: 1,995
Images: 11
Tut4u2 is an unknown
Send a message via AIM to Tut4u2
That's a nasty dent in the front quarter panel there.
o yea, big turbo, lol.

Che
Tut4u2 is offline  
post #14 of 19 Old 03-24-2004, 07:08 PM
WRXtuners Member
 
Kobiyashi's Avatar
 
Join Date: Feb 2003
Location: North Carolina
Posts: 578
Images: 2
Kobiyashi is more helpful than not
Quote:
Originally posted by fc735
18g is for ####sies



real men run a T61

this isnt me...its a guy on NASIOc (jared Nelson) that got his running now....

http://www.utracing.com/jared/100_0603_small.jpg

* for some reason.....that site dont like remote linking....klic teh leenk!

On the stock motor, sure =P

-kobi
Kobiyashi is offline  
post #15 of 19 Old 03-24-2004, 08:22 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2003
Location: Virginia
Posts: 54
Images: 3
delswrx is an unknown
Got the turbo in today, it looks great, they did a good job on the port and polish, can't wait to put it in this weekend.
delswrx is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome