Unsteady boost - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-08-2013, 12:26 AM Thread Starter
WRXtuners Member
 
Join Date: May 2013
Location: Michigan
Posts: 1
cheever is an unknown
Unsteady boost

I apologize if this is a topic that has been covered in huge detail, but I have no idea what to call this.

When I go WOT the turbo spools up but does not stay up. It varies from say ~15psi to ~9psi and back and forth. I can do it in 2nd through 5th gear (5 spd). I don't try to repeat this often but occasionally it will spike higher for a second. Should be running closer to 19psi.

Checked:
hoses - no leaks
compressor side of turbo occasionally has a small amount of oil pooled up.

There are a lot of checks I need to do. This is my first turbo car.

I have:
2002 wrx 2.0l
td05h-16g
grimmspeed boost control solenoid
AVP intercooler + blow off valve
Catless exhaust
has been tuned before
no recent changes.

May or may not be related but I do occasionally get a lean condition check engine light that comes on and off every once in a while. I have a wideband sensor in and, while the car does idle lean, it cruises at 14.7 and appears to have the proper startup enrichments. Also it tends to smell like a 2 stroke pretty often.

Thank you for reading this lengthy post. If you have any idea what this might be or be related to I could use a direction to search. Thanks again! ..any other info I'll gladly provide.
cheever is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On