Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   Unable to Pump gas-Evap code-HELP!!! (http://www.wrxtuners.com/forums/f72/unable-pump-gas-evap-code-help-25585/)

Hakmed711 03-24-2009 02:26 PM

Unable to Pump gas-Evap code-HELP!!!
 
For the past few months I have not been able to pump gas normally in my car, When I insert the nozzle into my tank and start pumping, the gas pump will automatically stop after about 1 gallon of gas, as if the tank was filled......I have to literally hold the nozzle at the tip of my tank and pump the gas at the slowest speed......... needless to say it takes me about 10 mins to fill up. In addition to this I intermittantly get a CEL for an EVAP code, I have changed the gas cap and the CEL has gone for now......

Some people have said there may be air in the tank
others say a hose leading to my gas tank could be loose or off....
Evap canister may be bad or my roll over valve....
:confused:

Please Help!!!!!!!!!!!!!!!!!!!

03 CrazyTaxi 03-25-2009 08:35 PM

Do you always fill up at the same station or various stations?

If it's various ones, I believe you have a bad charcoal canister. It's the large black box under the passenger side rear beneath the gas door. Fairly heavy for it's size too.

sleepr 03-25-2009 11:51 PM

which EVAP code specifically (what number)? There are several...

Hakmed711 03-26-2009 08:59 AM

I usually fill up at the same station -Sunnoco 93 Octane-

The code is: P0444
Evaporative emission control system purge control valve circuit low input-The CEL is not on at the moment and has not been for about two weeks now.......

dumdum 03-28-2009 09:58 AM

The gas cap only effects the P0457 which is a small leak.There is a one way valve that is in the charcoal box that is to supposed to purge when pressure builds up in the tank.It might be gunked up.Search P0444 on NAISIOC as I recently saw some threads with diagrams/pictures and solutions to fix it.

VD5505 03-28-2009 10:30 AM

get under that car and look to see if the fill tube leading from the gas neck to the tank is in some type of pinch if it it get a new filler neck hose or try and fix the one you have, over time those can collapse and pinch itself off try that and also look at the charcoal canister and examine that as well

Vertiay 04-18-2010 11:56 AM

I read alot of posts about removing the EVAP system and from what I understand if the 2 hoses that go to the EVAP canister located under the rear on the right behind the bumper the gas will not fill properly. Check to make sure the nipple that the hose goes to is not cracked and the hoses are not pinched. Also try pulling them off and try filling it..!Thumbs Up

kahawj 06-25-2010 02:31 PM

were you ever able to fix the problem with your fuel tank? im having the same problem too. took all my lines out and checked it for leaks and if any of the lines were clogged up but nothing.

Hakmed711 07-29-2010 01:15 PM

The problem went a way for a good while, however it came back recently and now the car drinks gas and hesitates a bit. I spoke with my Tuner and he has advised that he can delete the code which should eliminate the hesitation and gas milage issue. Until then I have to stay out of boost........


All times are GMT -5. The time now is 05:44 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.