Two Radiators in Two Months - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-16-2009, 04:10 PM Thread Starter
WRXtuners Member
 
Join Date: Oct 2009
Location: Vermont
Posts: 1
kdog is an unknown
Two Radiators in Two Months

I looked around a bit, but didn't see this specific problem anywhere. So...I had my radiator replaced in June '09, and last week my check engine light came on and I watched my temperature gauge climb into the red. I parked my car and called my mechanic, who checked it out. The coolant had suddenly completely drained, and he confirmed that my radiator was again leaking. It was replaced under warranty.

I've been stopping in every couple of days so we can all look at it, but I'm still smelling coolant and the container keeps emptying. They are ordering yet another radiator to be safe, but it appears that we should be checking something else, right? Any suggestions on what to look at?

(2003 WRX Wagon, no modifications, 107,000 miles, standard. Radiator replaced June 09 and October 09; Timing belt and water pump replaced in August 09.)
kdog is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-16-2009, 06:34 PM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
Didn't your mechanic pressure test the system? That would tell you where it is leaking from. Did you change your thermostat when you did the water pump?
The coolant smell could be coming from residual coolant being burnt off, which is pretty common.

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
post #3 of 4 Old 10-17-2009, 01:15 PM
WRXtuners Member
 
Join Date: Jun 2009
Location: Pennsylvania
Posts: 42
Marne_Aeok is an unknown
i just ent thru the same thing dude. i replaced rad a month ago. im gonna get thermostat changed and the water pump too just to be on the safe side
Marne_Aeok is offline  
post #4 of 4 Old 10-18-2009, 09:08 AM
WRXtuners Member
 
Join Date: Apr 2009
Location: North Carolina
Posts: 11
SlowbaruWRX is an unknown
Same happened to me, my coolant kept leaking and finally my rad blew. Got the rad replaced and found out that the leak was coming from a hose crossing my turbo. Yeah and I would also ask your mechanic if pressure tested the system.
SlowbaruWRX is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On