turbo spool not feeling so smooth - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 09-23-2008, 07:19 AM
WRXtuners Member
 
wrxshotta's Avatar
 
Join Date: Jun 2008
Location: Florida
Posts: 151
wrxshotta is on thin ice
turbo spool not feeling so smooth

Well im still on the TD04 for now but the turbo feels no where as smooth as my previous rex's..im curious to know if those that oil screen filter behind the turbo could be the cause? i have 60k miles and have no clue if it was ever changed.
wrxshotta is offline  
Sponsored Links
Advertisement
 
#2 Old 09-23-2008, 11:54 AM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Could be, but you just bought this thing used shortly before flight school. Correct? So, have you given it a once over? Changed all of the fluids in the engine? Does it have any mods other than the external mods viewable in your picture? Please, give us some more details to better serve you.
turmic is offline  
#3 Old 09-23-2008, 12:23 PM
WRXtuners Member
 
wrxshotta's Avatar
 
Join Date: Jun 2008
Location: Florida
Posts: 151
wrxshotta is on thin ice
right now it has a BOV and a TBE and an intake, im taking off the bov and the intake once i find a stock one to put on but i doubt these are related and yea i did do a one off..spent this weekend changing all fluids..but ive noticed this since the day i first test drove the car...also im gonna have it pro tuned when my BCS comes in..i know the TBE can affect it as well..but i have a 3 inch down pipe which midway underneath the car opens up to be a dump tube with a butterly valve that connects to the stock cat back so i can switch back and forth and in both stages, still feels the same way.
wrxshotta is offline  
#4 Old 09-23-2008, 12:40 PM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Im sure once you get the tune it will be fixed. I know the power deliver on my 07 (before my AP) was horrible to be honest. A Stage 1 map with 91 oct via my AP was oh so much better afterwards.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
#5 Old 09-23-2008, 07:01 PM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
Quote:
Originally Posted by wrxshotta View Post
right now it has a BOV and a TBE and an intake, im taking off the bov and the intake
And how would they not be related to your problems?Both those parts are absolutley the biggest causes of problems.This is common knowledge on EVERY Subaru site.And only the 2.5L turbo models with AVCS had the oil screens.

Homebrewed tuned with Opensource!
dumdum is offline  
#6 Old 09-23-2008, 08:49 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
True, i keep forgetting it's only 2.5L turbo models that have the screens. I don't know why.
turmic is offline  
#7 Old 09-24-2008, 07:15 AM
WRXtuners Member
 
wrxshotta's Avatar
 
Join Date: Jun 2008
Location: Florida
Posts: 151
wrxshotta is on thin ice
i thought that from 2005 and up subaru took them out...yeah i know about the avcs..but what about the oil feed line one
wrxshotta is offline  
#8 Old 09-25-2008, 11:13 AM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
Quote:
Originally Posted by wrxshotta View Post
i thought that from 2005 and up subaru took them out...yeah i know about the avcs..but what about the oil feed line one
None of those screens has anything to do with the 2.0L.Use the search button and you might find the actual TSB on the problem.

Homebrewed tuned with Opensource!
dumdum is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On