turbo - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 07-19-2011, 02:36 AM Thread Starter
WRXtuners Member
 
Join Date: Jul 2011
Location: Washington
Posts: 2
WashingtonZephyr is an unknown
Post turbo

my turbo is not spining up and boosting like it usta to the point of basicly no power when i want it, i mean my baby gots almost 200,000 miles on her... she diserves to act up a bit. but i have never worked on turbos i pulled rebuild and replace many egines so im not a newbie i just dont know anything about turbos ecept how they kind work. i need some help anybody.
WashingtonZephyr is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 07-19-2011, 06:36 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,977
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
What are you using to measure boost ?

Any CEL's ?

Is it the original snail in there ?

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #3 of 5 Old 07-20-2011, 01:03 AM Thread Starter
WRXtuners Member
 
Join Date: Jul 2011
Location: Washington
Posts: 2
WashingtonZephyr is an unknown
yeah its the original, there is a gauge in the car but its not psi, it reads MPa's i havnt figured out what that is either figured its metric or something.. when the car was running real well the gauge would read just alittle over 1 MPa, now it wont get over .05 MPa. and it will go into the negitive numbers when you let off the peddle. Also im working on getting the codes cleared, just replace the O2 sensor, and working on an exhaust code with a leak, but i was also wandeing if there is any codes or will the computer pull up a code for something wrong with the turbo....
WashingtonZephyr is offline  
post #4 of 5 Old 07-20-2011, 06:13 AM
WRXtuners Member
 
psinuse's Avatar
 
Join Date: Nov 2004
Location: Ohio
Posts: 3,093
psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to
Quote:
Originally Posted by WashingtonZephyr View Post
yeah its the original, there is a gauge in the car but its not psi, it reads MPa's i havnt figured out what that is either figured its metric or something.. when the car was running real well the gauge would read just alittle over 1 MPa, now it wont get over .05 MPa. and it will go into the negitive numbers when you let off the peddle. Also im working on getting the codes cleared, just replace the O2 sensor, and working on an exhaust code with a leak, but i was also wandeing if there is any codes or will the computer pull up a code for something wrong with the turbo....
Sure that isn't .1 MPa and .05 MPa? Cause 1 MPa is 140psi.

Resident Grumpy Old Man(Keith)
03 SRP 2.34L
08' LGT Gears...
psinuse is offline  
post #5 of 5 Old 07-20-2011, 06:43 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,977
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
^^ Keith is right, use this tool/link. You mean .10 MPa and .05 MPa

.10 is about right for a stock 02 WRX. Negative is vacuum (normal)

The ECU will not really give you a code specifically for the turbo going but throws codes for overboosting/fuel cut/etc..etc..

Get the codes read and rule out a boost leak. What have you played with under the hood as of late?
One of the common areas for boost leaks is the elbow from the turbo to the TMIC.
2-The turbo inlet hose itself (If it's cracked/torn which happens all the time because they become brittle after a couple years).
3-And the BPV gasket to the TMIC.

Post up your findings.

Kilopascal [kPa] To Psi [psi] Converter

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On