Sounds like lifters need adjustment! - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-12-2003, 04:39 PM Thread Starter
WRXtuners Member
 
Join Date: Sep 2003
Location: Divide, Colorado
Posts: 9
jdwrx is an unknown
Post Sounds like lifters need adjustment!

Ok another SSO question:
My engine ticks like chchhchchchchchchch...on any other car I would say my lifters need adjustment....but I heard sometimes its only the injectors making the noise. Does all WRX make this noise...I have around 20000 miles ... any one else have this sound....
ps do not know any other WRX owner in this town !Cry!
jdwrx is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-12-2003, 04:56 PM
WRXtuners Member
 
fc735's Avatar
 
Join Date: Apr 2003
Posts: 1,890
Images: 12
fc735 is more helpful than not
Send a message via AIM to fc735
is it real bad...or just a lil tick? if you run synthetic, some have had issues with increased lifter noise. now me, on the other hand.....has a nice little knock fomin from the lash adjuster...i spit a shim out again....arrgh.

oh well. now we build bigger. 19psi..thats always good.....

by the way...adjusting them....THAT is fun. it involves a special compressor to release tension off of the follower, and changing the shim thickness to compensate for lash...NOT FUN!!!
fc735 is offline  
post #3 of 6 Old 09-12-2003, 05:00 PM Thread Starter
WRXtuners Member
 
Join Date: Sep 2003
Location: Divide, Colorado
Posts: 9
jdwrx is an unknown
Shi*, No it's not that bad....Subaru Dealer said it was injectors...but they screwed me the last time I was there....there just mad because I modified it!

I can adjust Honda lifters pretty easy...but WRX...a diff animal!

I live a 9100 ft and I drive up 3000 ft daily and put a min of 3500 miles a month on it...yea I drive the shi# out of it. I will just turn up the radio then i want be able to hear them....chat at me!
jdwrx is offline  
post #4 of 6 Old 09-12-2003, 06:03 PM
WRXtuners Member
 
SloRice's Avatar
 
Join Date: Apr 2003
Location: Ohio
Posts: 329
Images: 4
SloRice is an unknown
Send a message via AIM to SloRice
If it's not a loud ticking, that's normal. All the WRX motors that i've heard make that noise.

Tim
SloRice is offline  
post #5 of 6 Old 09-13-2003, 12:14 PM
WRXtuners Member
 
zoinks's Avatar
 
Join Date: Jun 2003
Location: Oregon
Posts: 149
zoinks is an unknown
Send a message via AIM to zoinks
Mine has the same thing....the dealer said that it was just typical valvetrain noise for the flat four. It's annoying though.
zoinks is offline  
post #6 of 6 Old 09-26-2003, 02:58 PM
Kev
WRXtuners Member
 
Join Date: Sep 2003
Location: NY
Posts: 16
Kev is an unknown
Same here, if it is VERY loud get it checked. My guess it is the same light ticking that every Subaru has, my 2.5 RS did the exact same thing.
Kev is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On