Smoke from front right engine - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-17-2012, 11:49 AM Thread Starter
WRXtuners Member
 
Join Date: Sep 2012
Location: California
Posts: 2
Kurt_Sweethat is an unknown
Smoke from front right engine

I own a 04 wrx, stock motor with 130k on it, and when my engine heats up to normal operating temperature it starts to smoke when I come to a stop. I if I sit long enough, the smoke will come out of my scoop and front right hood area. Now, I do have a split in my right cv boot and there is grease that has been flung out from it, I think it's from that. I have a new one on the way. My question is, could it be from somewhere else? Cause I can't pinpoint the exact cause of the smoke and burning smell. I just want to make sure I'm not missing anything.. Anyone else have a similar problem? Thanks!
Kurt_Sweethat is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-17-2012, 02:22 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,981
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
The grease from the boot can smell bad. It's probably the issue. Fix it and clean everything real well and see if it persists.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #3 of 6 Old 09-17-2012, 05:11 PM
WRXtuners Member
 
AllExtinct's Avatar
 
Join Date: Mar 2010
Location: Pennsylvania
Posts: 607
AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful
An easy way to check to see if its the grease is after your done driving park and let the engine idle for a few minutes and see if the smoke stops.

Good luck.

Cobb Accessport Stage 2.
JDM ej205 swap.

Hakuna Matata.

Chuck.
AllExtinct is offline  
post #4 of 6 Old 09-17-2012, 09:13 PM
WRXtuners Member
 
sleepr's Avatar
 
Join Date: Dec 2005
Location: Asia
Posts: 914
Images: 13
sleepr is known to be trustworthy and helpful sleepr is known to be trustworthy and helpful
Garage
sounds similar to the symptoms that preceded the replacement of my turbo...

Matt
70 to 100 faster than you can say "whoooossshh!"
sleepr is offline  
post #5 of 6 Old 09-18-2012, 06:24 AM Thread Starter
WRXtuners Member
 
Join Date: Sep 2012
Location: California
Posts: 2
Kurt_Sweethat is an unknown
Thanks. Hopefully the cv boot will fix it.

Sent from my ADR6400L using AutoGuide.Com Free App
Kurt_Sweethat is offline  
post #6 of 6 Old 12-02-2012, 07:51 PM
WRXtuners Member
 
Join Date: Dec 2012
Location: Arizona
Posts: 1
derek86ux is an unknown
i have this exact same problem. have you figured out what it was yet? please let me know.
derek86ux is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome