rough idle at cold temps/ o2 sensor issues - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 Old 03-23-2012, 11:24 PM
WRXtuners Member
 
rex2002's Avatar
 
Join Date: Mar 2009
Location: Tennessee
Posts: 308
Images: 7
rex2002 is known to be trustworthy and helpful rex2002 is known to be trustworthy and helpful
Send a message via AIM to rex2002 Send a message via Skype™ to rex2002
rough idle at cold temps/ o2 sensor issues

ok 1st off ive been running stage 2 cobb map with all supporting mods for close to a year with no problems. no cels what so ever.i now have 2 cel's p0031( h025 heater control circuit low ,bank 1 sensor) & p1130 (front oxygen sensor circuit malfunction,open circuit). once i start the car when its cold it idles around 1300rmps, but it has rough idle to the point that it sounds like its going to die.after i drive it and it warms up a little the rmp range is back to normal,but i have a lot of stutter/hesitation when driving. can anyone help me with this issue.
rex2002 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-24-2012, 11:22 AM
WRXtuners Member
 
bad grocerygetter's Avatar
 
Join Date: May 2010
Location: Oklahoma
Posts: 453
Images: 2
bad grocerygetter is a helpful contributing member
When was the last tune up? Mine was throwing some weird codes also when all I needed was a fuel filter.

Kevin.
Cobb ap stage 2 ots, catless uppipe, catless turboback, Cobb Sf intake.
bad grocerygetter is offline  
#3 Old 03-24-2012, 11:59 AM
WRXtuners Member
 
rex2002's Avatar
 
Join Date: Mar 2009
Location: Tennessee
Posts: 308
Images: 7
rex2002 is known to be trustworthy and helpful rex2002 is known to be trustworthy and helpful
Send a message via AIM to rex2002 Send a message via Skype™ to rex2002
Quote:
Originally Posted by bad grocerygetter View Post
When was the last tune up? Mine was throwing some weird codes also when all I needed was a fuel filter.
just changed the oil less than 2 weeks ago,and my fuel filter is due to be replaced on 5/30. spark plugs were changed shortly after the car was flashed. i haven't changed the coolant in a while. also checked tranny fluid during oil change and it was in normal range,shifts fine. stage two map says i need a high-flow catalytic converter,but on my setup ive got no cats at all and had no cel issues at all. after a year of almost being at stage 2 would my no cat setup finally catch up to me and throw those codes. there's a protune shop with awd dyno that supports cobb about 2 hour drive from me. would it be smart to go get a pro tune to make a custom map with the no cat setup?
rex2002 is offline  
#4 Old 03-24-2012, 02:02 PM
WRXtuners Member
 
bad grocerygetter's Avatar
 
Join Date: May 2010
Location: Oklahoma
Posts: 453
Images: 2
bad grocerygetter is a helpful contributing member
I would if it were me, but I would make sure that the car has no other issues first. Hmmm... I dunno man. Let's wait and see who else chimes in. Keith? Kirt? What you guys think?

Kevin.
Cobb ap stage 2 ots, catless uppipe, catless turboback, Cobb Sf intake.
bad grocerygetter is offline  
#5 Old 03-24-2012, 09:07 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Could be a front 02 sensor...I'm not quite sure. I'd get it checked out to make sure its not something mechanical before I'd be thinking about getting a tune.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#6 Old 03-24-2012, 11:34 PM
WRXtuners Member
 
rex2002's Avatar
 
Join Date: Mar 2009
Location: Tennessee
Posts: 308
Images: 7
rex2002 is known to be trustworthy and helpful rex2002 is known to be trustworthy and helpful
Send a message via AIM to rex2002 Send a message via Skype™ to rex2002
going to replace the front o2 sensor and clear the code and hope the code doesn't come back
rex2002 is offline  
#7 Old 03-25-2012, 07:11 AM
WRXtuners Member
 
bad grocerygetter's Avatar
 
Join Date: May 2010
Location: Oklahoma
Posts: 453
Images: 2
bad grocerygetter is a helpful contributing member
If that doesn't work try doing a data log when the car is acting up. Let us see what's going on. Maybe a video as well

Kevin.
Cobb ap stage 2 ots, catless uppipe, catless turboback, Cobb Sf intake.
bad grocerygetter is offline  
#8 Old 03-25-2012, 09:49 AM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Check this website out...it was a quick google search for the root cause of your P0031 heater control circuit low.

P0031 Oxygen (A/F) Sensor Heater Control Circuit Low (Bank 1 Sensor 1) - DTC Code

So, basically that is two CELs pointing the finger at your front 02 sensor.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#9 Old 03-25-2012, 12:37 PM
WRXtuners Member
 
rex2002's Avatar
 
Join Date: Mar 2009
Location: Tennessee
Posts: 308
Images: 7
rex2002 is known to be trustworthy and helpful rex2002 is known to be trustworthy and helpful
Send a message via AIM to rex2002 Send a message via Skype™ to rex2002
ordered a new o2 sensor.ill post back my findings once i install it and clear the cel. thanks for the help everyone
@turmic that link was very helpful
rex2002 is offline  
#10 Old 03-25-2012, 09:29 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
My front 02 Sensor crapped out about a year ago and was causing all sorts of problems. Its not a problem man...I hope it fixes your problem.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#11 Old 03-30-2012, 07:06 PM
WRXtuners Member
 
rex2002's Avatar
 
Join Date: Mar 2009
Location: Tennessee
Posts: 308
Images: 7
rex2002 is known to be trustworthy and helpful rex2002 is known to be trustworthy and helpful
Send a message via AIM to rex2002 Send a message via Skype™ to rex2002
ok got the new o2 sensor in and the o2 code is now gone, but im still throwing p0031( h025 heater control circuit low ,bank 1 sensor) even with the cobb ecu code reset and no luck.. any other ideas what that p0031 code is,what can i do to fix it.
rex2002 is offline  
#12 Old 04-02-2012, 06:20 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
^Did you buy an OEM o2 sensor?

Or a Bosch ?

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#13 Old 04-06-2012, 03:54 PM
WRXtuners Member
 
rex2002's Avatar
 
Join Date: Mar 2009
Location: Tennessee
Posts: 308
Images: 7
rex2002 is known to be trustworthy and helpful rex2002 is known to be trustworthy and helpful
Send a message via AIM to rex2002 Send a message via Skype™ to rex2002
no my dumb ass bought an o2 senor when i should of bought an air/fuel o2 sensor. just put the right sensor in and now no codes. while the car was riding like shit i was hitting 19lbs of boots on the stock tdo4 on a cobb stage 2 map.i guess with the air/fuel being jacked up it made the car pull a lot harder. i guess theres a little more wiggle room in that tdo4. is 19lbs safe on a tdo4. now that im back to the right air/fuel im back at 16lbs of boost.
rex2002 is offline  
#14 Old 04-06-2012, 04:58 PM
WRXtuners Member
 
bad grocerygetter's Avatar
 
Join Date: May 2010
Location: Oklahoma
Posts: 453
Images: 2
bad grocerygetter is a helpful contributing member
Safe for the turbo? Yeah, maybe. Right for the map you are on? No, not at all. Glad you are back to correct specs. It's said that anything over about 20 lbs and the td04 just becomes a flame thrower. Just out of its efficiency range.

Kevin.
Cobb ap stage 2 ots, catless uppipe, catless turboback, Cobb Sf intake.
bad grocerygetter is offline  
#15 Old 04-07-2012, 03:37 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,368
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Glad you figured it out

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On