Rear o2 sensor problems - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 06-21-2008, 05:57 AM Thread Starter
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
Rear o2 sensor problems

Recently my o2 sensor came unclipped from the rest of the harness. I noticed the CEL came on but didn't catch it right away. The plugs on both ends(one going to the o2 sensor the other to the ECU) were drug on the road and wore down to the point that they can't be reconnected. Yesterday I decided to crawl under the car to try and fix the problem. I stripped the wires on the o2 sensor side, put in some extensions and put connectors on the ends of each wire. When I went to do the same to the wires on the ECU side, the colors were different.

What I need to find what color wires on the ECU side connect to what wires on the o2 sensor side so I can get everything hooked up and clear my CEL so that I can pass emissions.

I've searched NASIOC, Scoobymods, posted on both with no success. I downloaded the service manual for a 2002 impreza but could not find the info I am looking for.


The wires on the ECU side of the plug are Yellow w/ a Red line, Blue, White and White.

The wires on the o2 sensor side are Blue, White, Black and Black.

I am headed down to the beach later today and would like to take my WRX so I don't have to drive my 7-8mpg truck 300 miles. If anyone could find an answer for me that would be great. The only way I know is to have someone crawl under their '03 and pull the cover protecting the wires back to see which wire goes with which wire.
WRXtreme is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 06-21-2008, 07:40 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
That or find someone that has a multimeter to read the current through each of the line. Im not much on electronics, but my friend is an electrician. Thats what he said to do.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #3 of 11 Old 06-21-2008, 08:29 AM Thread Starter
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
I do have a multimeter, but I hate wiring. I have had other people recommend that as well, but don't really know what I am doing when it comes to reading the current.
WRXtreme is offline  
post #4 of 11 Old 06-21-2008, 09:17 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,977
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Ask Mike Nagy (nagyhead) He might go under his for you. Send him a PM.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
post #5 of 11 Old 06-21-2008, 10:22 AM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
I dont know right off hand but i will pull my car in at work today and verify the wires for you.

BTW your refering to the rear o2 right.

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
post #6 of 11 Old 06-21-2008, 10:27 AM Thread Starter
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
That is correct.
These are the colors I am dealing with right now.
The wires on the ECU side of the plug are Yellow w/ a Red line, Blue, White and White.
The wires on the rear o2 sensor side are Blue, White, Black and Black.

Not sure why they are different colors but only reason I could think of was that the o2 sensor is from a different manufacturer.
WRXtreme is offline  
post #7 of 11 Old 06-22-2008, 01:48 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
I feel you about not liking electrical stuff. I know a little bit about it, but it makes my head hurt doing it for some reason. I usually have a friend help out.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
post #8 of 11 Old 06-22-2008, 02:23 PM
WRXtuners Member
 
wrxshotta's Avatar
 
Join Date: Jun 2008
Location: Florida
Posts: 151
wrxshotta is on thin ice
Quote:
Originally Posted by WRXtreme View Post
That is correct.
These are the colors I am dealing with right now.
The wires on the ECU side of the plug are Yellow w/ a Red line, Blue, White and White.
The wires on the rear o2 sensor side are Blue, White, Black and Black.

Not sure why they are different colors but only reason I could think of was that the o2 sensor is from a different manufacturer.
nah its not from a different manufacturer i recently swapped out mine and i had the same Blue, White, Black and Black and the yellow and what not on the ecu side... i actually had some one write down which wires were what...i will see if i can locate where i put that paper for you.
wrxshotta is offline  
post #9 of 11 Old 06-22-2008, 08:37 PM
WRXpert
 
nagyhead's Avatar
 
Join Date: Jul 2006
Location: Pennsylvania
Posts: 2,181
Images: 4
nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to nagyhead is a WRX expert worth listening to
I just looked under my car and my o2 has 4 wires; white , blue , black and black. My ecu side has blue, white, yellow/red, and a white/black
O2-------------------ecu
white-------------blue
blue ---------------white
black-----------yellow/red stripe
black-------------white/black stripe


that is how it is on my 03. you have 2 whites instead of a blue and a white, so i'm not sure.

Dom Tuned 2003 WRX Wagon
251.3 WHP
235.8 WTQ

If it's worth doing, it's worth overdoing
nagyhead is offline  
post #10 of 11 Old 07-04-2008, 06:52 PM Thread Starter
WRXtuners Member
 
WRXtreme's Avatar
 
Join Date: Mar 2003
Location: Pennsylvania
Posts: 1,654
WRXtreme is more helpful than not
Send a message via AIM to WRXtreme
Thanks for the help with this. I just got around to getting to work on my car and after reconnecting the battery and letting it idle for about 5 mins, no CEL. I'll let you know how it is after a hundred miles or so. Thanks again!!
WRXtreme is offline  
post #11 of 11 Old 04-29-2013, 12:58 AM
WRXtuners Member
 
Join Date: Aug 2011
Location: Pennsylvania
Posts: 1
btrux0611 is an unknown
Quote:
Originally Posted by nagyhead View Post
I just looked under my car and my o2 has 4 wires; white , blue , black and black. My ecu side has blue, white, yellow/red, and a white/black
O2-------------------ecu
white-------------blue
blue ---------------white
black-----------yellow/red stripe
black-------------white/black stripe


that is how it is on my 03. you have 2 whites instead of a blue and a white, so i'm not sure.
Hey i ripped the plug right off the fire wall harness that goes to the rear 02 sensor. Would be great if some one could tell me which color go to which ?? Thanks in advance !
btrux0611 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On