Puts on a perrin downpipe HKS bov and HKS Exhuast - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 09-10-2003, 11:13 PM
WRXtuners Member
 
Join Date: Jul 2003
Location: Pennsylvania
Posts: 42
wrxnmh03 is an unknown
Unhappy Puts on a perrin downpipe HKS bov and HKS Exhuast

I put on the bov it ran good i was getting 10 pounds of boost then I put on THe downpipe and exhuast and know it seems to lose boost like it is leaking. I think it is the wastegate does anybody expernence thing the like and if it is the wastegate how do i fix it.
wrxnmh03 is offline  
Sponsored Links
Advertisement
 
#2 Old 09-16-2003, 10:33 AM
WRXtuners Member
 
wrxecution's Avatar
 
Join Date: Jun 2003
Location: Tennessee
Posts: 307
wrxecution is an unknown
first off check your exhaust to make sure everything is tight and you have no leaks then do the same for the bov sometimes the gaskets dont do their job as effective when you reuse them. btw did you take off you ic to install the exhaust if you did check and make sure its on tight too
wrxecution is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On