problem with tgv's and other codes - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 13 Old 02-26-2012, 09:13 AM Thread Starter
WRXtuners Member
 
Join Date: Feb 2012
Location: Ohio
Posts: 6
joegamma1 is an unknown
problem with tgv's and other codes

2006 WRX, VF22, front mount, down pipe(catless) AndI'm not sure what else it has yet, I haven't seen boost past 8-9 psi except once, it went to 14psi, but went back to limp mode right away(cruise falshing, loss of power and spool), I think it has a tune but I can't be sure, it idles fine with fluctuation once in awhile. I just bought my car and I am now having a cel:
checked the codes:
p2017, intake mani runner position sensor/switch circuit high bank 1

p0138, o2 circuit high volt bank 1 sensor 2

p2006 intake mani runner control stuck closed bank 1

p0171, system too lean bank 1

I was wondering if anyone has had this problem before and might have a fix?
Best guess i have is that the Tgv sensor is bad and I plan on replacing it. It is the sensor right by the turbo so....

Thanks for any suggestions
joegamma1 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 02-26-2012, 09:43 AM
WRXtuners Member
 
AllExtinct's Avatar
 
Join Date: Mar 2010
Location: Pennsylvania
Posts: 596
AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful
So you just bought your car with a FMIC,catless DP and others not listed. Well my guess is going to be you just bought someone else's headache.


Good luck man.

Cobb Accessport Stage 2.
JDM ej205 swap.

Hakuna Matata.

Chuck.
AllExtinct is offline  
post #3 of 13 Old 02-26-2012, 09:46 AM Thread Starter
WRXtuners Member
 
Join Date: Feb 2012
Location: Ohio
Posts: 6
joegamma1 is an unknown
Yes, it ran great on the test drives, did not have a boost gauge but pulled hard....but thanks for the reply....helped a lot .
joegamma1 is offline  
post #4 of 13 Old 02-26-2012, 09:52 AM
WRXtuners Member
 
AllExtinct's Avatar
 
Join Date: Mar 2010
Location: Pennsylvania
Posts: 596
AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful
Not really sure about 06's but when I went catless in my 02 I had to tune for CEL for the 02 sensor.
Does it have a catback exhaust? Intake? MBC?

Cobb Accessport Stage 2.
JDM ej205 swap.

Hakuna Matata.

Chuck.
AllExtinct is offline  
post #5 of 13 Old 02-26-2012, 10:20 AM Thread Starter
WRXtuners Member
 
Join Date: Feb 2012
Location: Ohio
Posts: 6
joegamma1 is an unknown
Catless downpipe, factory catted mid, aftermarket muffler, AEM intake, no mbc, no pill either(picking one up Tuesday)
joegamma1 is offline  
post #6 of 13 Old 02-26-2012, 12:51 PM
WRXtuners Member
 
AllExtinct's Avatar
 
Join Date: Mar 2010
Location: Pennsylvania
Posts: 596
AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful AllExtinct is known to be trustworthy and helpful
Unless you have some kind of EM your going to have alot of problems with the mods on your car.
There are alot of helpfull people on here that will most likely tell you the same thing.
I dont consider myself a veteran Suby mechanic but I would try and find out what EM you have from previous owner and if there is not any don't drive that car again till you get all the stock stuff back on it before it does more damage than it has already done.
The intake alone is messing things up.

Good Luck man.

Cobb Accessport Stage 2.
JDM ej205 swap.

Hakuna Matata.

Chuck.
AllExtinct is offline  
post #7 of 13 Old 02-26-2012, 03:30 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2012
Location: Ohio
Posts: 6
joegamma1 is an unknown
It's obviously tuned, but when it was traded in; the previous owner took parts off, boost gauge for sure. My question was; with the codes above, is there anything that stands out to anyone? I.e. a toasted tgv motor and/or sensor. I am well aware that I need to at the very least check what tune is on it. Your posts have been a total waste if my time, but thanks.
joegamma1 is offline  
post #8 of 13 Old 02-26-2012, 09:05 PM
WRXtuners Member
 
BLAZE2099's Avatar
 
Join Date: Jan 2011
Location: Pennsylvania
Posts: 2,636
Images: 6
BLAZE2099 is known to be trustworthy and helpful BLAZE2099 is known to be trustworthy and helpful
The tune you think you have is no longer good. The guy messed with things before you got it. Get it to a tuner, or get OS, or an AP. and go from there with OTS mapping that may be within what your car has done to it... Or turn it stock again.

He wasn't bashing you. He was trying to warn you before you kill your engine

Randy-
2002 blaze WRX- sold:(
2004 Wrx-sold
2011 Wrx limited
99 Fozz- sold
Eagle eye crew
BLAZE2099 is offline  
post #9 of 13 Old 02-27-2012, 09:01 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2012
Location: Ohio
Posts: 6
joegamma1 is an unknown
Yea, I know it needs to go to the tuner, which is part of the plan, I need to know what tune is on it and by what means.
I was asking for advice on the tgv's and the codes pertaining to them, so I dont cause myself more problems on the way to the tuner-which I already know is the first step to getting it to run properly with the setup in place.
joegamma1 is offline  
post #10 of 13 Old 02-27-2012, 10:32 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
So, wait a minute. You took the car for a test drive before or after the previous owner took parts off? And if you don't know what they took off then we can't tell you if its a sensor failure or tgv failure. It could just be that the previous owner took off some performance parts and now the car's tune is so far out of spec that you're throwing random CELs. Sooo...sadly its pretty hard to diagnose a car over the internet. The obvious....the tuner should be the solution to all your questions see as he can physically see what your sensors are doing and what tune is on the car now. If your tuner is any kind of professional they'll be able to diagnose it and figure it all out. Sorry, thats about as much help as most of us can give.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
post #11 of 13 Old 02-28-2012, 07:39 AM Thread Starter
WRXtuners Member
 
Join Date: Feb 2012
Location: Ohio
Posts: 6
joegamma1 is an unknown
Test drove it after. It was a trade-in vehicle. It ran great during the test drives, and the only thing I've found "missing" is the boost gauge (line under the dash). I'll just get it to my tuner, and go from there. Thanks
joegamma1 is offline  
post #12 of 13 Old 02-28-2012, 10:21 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
That is odd that it drove fine for more than one test drive. Good luck Joe.

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
post #13 of 13 Old 02-29-2012, 06:41 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,977
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
I have seen where the punks at the dealers start taking parts off cars when in "make-ready"... Just saying, it could be anything.

Paul
2002 WRX Sold
2007 WRX Sold
2007 STi totaled
2007 Foz XT sold
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On