Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   Power steering pump whining (http://www.wrxtuners.com/forums/f72/power-steering-pump-whining-23742/)

KillerRabbit 07-15-2008 09:26 AM

Power steering pump whining
 
well i took my power steering pump pressure hose off of it, to but a inlet hose and aps tgv deletes on, i needed it out of my way. I got it all done and i put it back on started it up and its screaming at me. I got air in the line, and to make it worst my pump has been trying to go out on me. So i got a new one and need some advice of what i should do to put it back in and fill it up correctly.

and also is there a bleeder screw somewhere?

lend me your knowledge.

nagyhead 07-15-2008 02:57 PM

To bleed it you just turn the wheel left and right until all the air is out. Also, don't fill it up with power steering fluid, it takes ATF.

KillerRabbit 07-15-2008 10:22 PM

sweet thank you sir!

GreddyUno 03-11-2009 07:36 AM

Hi

I need some advice on the same topic

I have had to rebuild my motor and in the process had the power steering pump and all other parts removed. I have re installed the PS pump and now it seems that the pump is screaming as well as working intermittently .... i have tried the full bleeding story but still does the same thing . The pump was 100% before i removed it. Is there anything else that i am missing out on ?

Please help!!!!

Thx
D

Doug15 11-30-2009 12:57 PM

I don't know if you managed to sort out your problem, but follow the link below to download a complete workshop manual for your WRX.
Hope you come right.
[url=http://ken-gilbert.com/impreza-manuals]Impreza Manuals | ken-gilbert.com[/url]
!Thumbs Up
DC

BSKwagon61 02-27-2010 04:52 PM

Hey, I literally just joined 5 minutes ago (sorry if this thread has been dead for a while, but seriously need help). last night my friend an i went out drifting in the snow, and when we were donethe steering wheel was fighting me at idle, but if i rev the power steering comes back on. so if the car isn't moving and its idling the wheel wont turn, but as soon as you give it gas and start to move the wheel moves. I have no idea what could be wrong, just incase it's a 02 WRX wagon, 118,000 mi.

Immediate help would be greatly appreciated, thanx.

man show 02-28-2010 11:35 AM

I have a feeling the WRX power steering unit may be attached to the engine via one of the two drive belts located on the front of the engine. They're very easily accessible, so you might want to check the tension on both of them and make sure the belt didn't slip off one of the wheels or simply become loose. I remember I was driving stupidly in one of my old cars and the belt slipped off one of the pulley wheels and I lost my power steering and some other stuff, but once I put the belt back on and tightened it up, everything worked again. You might want to start there...

newtothegame 02-28-2010 01:39 PM

Might have fried the pump also. I have read countless people doing this when playing in the snow.

man show 02-28-2010 08:06 PM

...and that was my plan B. I just didn't want to scare the poor guy right off the bat. Might as well try the easy/cheap fixes first ;)

BSKwagon61 02-28-2010 08:15 PM

thanx guys

BSKwagon61 03-02-2010 04:51 PM

new info. I noticed that the power steering only doesn't work when the engine is warm. so when its cold and idling it works fine. still haven't gotten the chance to take a look under the hood to check the belt tension, waiting on decent weather.

Tberg44 09-01-2010 12:46 PM

I have the exact same problem bskwagon61... What did you end up doing to fix it? Thanks for the help!


All times are GMT -5. The time now is 08:46 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.