Possibly too much boost? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-07-2010, 07:14 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 8
newwrxowner is an unknown
Possibly too much boost?

I just purchased a 2004 wrx and recently put a glowshift boost gauge in it. I noticed that the gauge reads close to 16 psi in 4th and 5th and around 14 in 2nd and 3rd. I know the gauge is cheap and could just be the gauge reading inaccuratly. But I noticed that the heat shield was gone from the turbo and the lock nut on the waste gate actuator arm was turned way out so it was not "locking". So the previous owner may have adjusted the wastegate arm to achieve more boost. I would like to know if I should re-adjust the arm to get the boost back to around 13 psi in higher gears.
newwrxowner is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-08-2010, 08:22 AM
WRXtuners Member
 
Join Date: Feb 2010
Location: Texas
Posts: 36
sivart08 is an unknown
is everything stock on the car?? and what kind of glowshift do you have becasue there pretty good... make sure eveything is hooked up the right way also..
sivart08 is offline  
post #3 of 3 Old 04-09-2010, 02:19 PM Thread Starter
WRXtuners Member
 
Join Date: Mar 2010
Location: Wisconsin
Posts: 8
newwrxowner is an unknown
It has a ProDrive muffler (not cat-back) and thats all that was changed motor wise.
newwrxowner is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome