Please HELP!! (I'm an idiot) - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 Old 02-12-2007, 04:10 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2007
Location: Florida
Posts: 7
wrxsm is an unknown
Exclamation Please HELP!! (I'm an idiot)

I recently replaced the stock turbo in my 03 WRX with another, and after installing it, you could hear the turbo spool but it doesn't seem to be building boost. Upon reaching 3-4 RPM's the car starts to hesitate really, really bad. The car doesn't go above 80 mph...infact the faster I go the slower it accelerates. I've been told over and over its a leak in the vaccuum line, and I've checked my work 6 or 7 times now, but I still cannot find the problem.

Trying to get this shit fixed so I can get down to Florida ASAP. Please help immediately!

Captain Out.
wrxsm is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 02-12-2007, 04:29 PM
WRXtuners Member
 
ohhNOwrx's Avatar
 
Join Date: Jan 2006
Location: Iowa
Posts: 242
ohhNOwrx is an unknown
Did you replace it with a stock turbo?
ohhNOwrx is offline  
post #3 of 23 Old 02-12-2007, 06:35 PM
WRXtuners Member
 
mxboy15u's Avatar
 
Join Date: Oct 2005
Location: North Carolina
Posts: 1,470
mxboy15u is an unknown
How is it tuned? What are your other mods?
mxboy15u is offline  
post #4 of 23 Old 02-12-2007, 11:42 PM
WRXtuners Member
 
Join Date: Sep 2006
Location: Nevada
Posts: 2,245
WRXKidid775 is more helpful than not
i think he replaced it with a stocker. check the waste gate actuator arm it might be too loose.

Robby
02 rex is gone.
I defected to an evo :)
Evo is gone :(
Now I got nothing.
WRXKidid775 is offline  
post #5 of 23 Old 02-13-2007, 01:00 AM Thread Starter
WRXtuners Member
 
Join Date: Feb 2007
Location: Florida
Posts: 7
wrxsm is an unknown
yeah its another stock
wrxsm is offline  
post #6 of 23 Old 02-13-2007, 01:06 AM Thread Starter
WRXtuners Member
 
Join Date: Feb 2007
Location: Florida
Posts: 7
wrxsm is an unknown
waste gate actuator arm seems to be all right....mods include:
headers, up pipe, downpipe, exhaust,blow off valve, turbo timer, intake, and boost controller.

called subaru and they said it might be the first cylinode on the passenger side. guess its an acutator of some sort?
or they said it might be the vaccuum line from the cylinode to the turbo...but it still looks okay to me.

any other ideas?
wrxsm is offline  
post #7 of 23 Old 02-13-2007, 01:53 AM
WRXtuners Member
 
Black05WRX's Avatar
 
Join Date: Sep 2006
Location: Colorado
Posts: 487
Images: 10
Black05WRX is an unknown
Boost leak. Have you checked for any? If your leaking your not going to build pressure.

Looking it over, I dont know how you can really test for a vac leak, I know on the DSM's you just made your own to build pressure and listen for leaks.

Another way to do it, is get some soapy water, turn the car on and see if you can see any air come up while at idle. Also do you have a guage? Is it reading normal vac?
Black05WRX is offline  
post #8 of 23 Old 02-13-2007, 01:59 AM
WRXtuners Member
 
Join Date: Sep 2006
Location: Nevada
Posts: 2,245
WRXKidid775 is more helpful than not
i agree with black05 boost look probably. check your vac line from the bcs for a restrictor pill, that might be missing as well and could cause boost to act funny

Robby
02 rex is gone.
I defected to an evo :)
Evo is gone :(
Now I got nothing.
WRXKidid775 is offline  
post #9 of 23 Old 02-13-2007, 02:02 AM
WRXtuners Member
 
Black05WRX's Avatar
 
Join Date: Sep 2006
Location: Colorado
Posts: 487
Images: 10
Black05WRX is an unknown
Its what I have experince with my DSM's each time it was something stupid as something not being on correctly.

You never have truly worked on a car till you do something stupid and simple
Black05WRX is offline  
post #10 of 23 Old 02-13-2007, 07:52 AM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
Quote:
Originally Posted by wrxsm
waste gate actuator arm seems to be all right....mods include:
headers, up pipe, downpipe, exhaust,blow off valve, turbo timer, intake, and boost controller.

called subaru and they said it might be the first cylinode on the passenger side. guess its an acutator of some sort?
You aparently have an aftermarket boost controler.Subaru was talking about the factory solenoid you are probably no longer using....

Homebrewed tuned with Opensource!
dumdum is offline  
post #11 of 23 Old 02-13-2007, 11:40 AM
WRXtuners Member
 
Join Date: Apr 2005
Location: Michigan
Posts: 924
shamrock is an unknown
Get rid of the boost controller, it dosent help. More harm than good

_Ryan_
2004 Wrb "BUGEYE"
http://www.misubie.com/
shamrock is offline  
post #12 of 23 Old 02-15-2007, 05:33 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2007
Location: Florida
Posts: 7
wrxsm is an unknown
checked for vaccum leak holds vaccum good at idle when in nuetral car will rev fine but in a gear doesnt want to get above 2000 with out fighting runs rough in gear while black smoking bad back fires from time to time top speed 70 today any more ideas anyone
wrxsm is offline  
post #13 of 23 Old 02-15-2007, 07:00 PM
WRXtuners Member
 
Kjott21's Avatar
 
Join Date: May 2006
Location: Pennsylvania
Posts: 763
Kjott21 is known to be trustworthy and helpful Kjott21 is known to be trustworthy and helpful Kjott21 is known to be trustworthy and helpful
Garage
It sounds like a boost leak to me too. Check all the hoses from the turbo to intercooler and intercooler to the throttlebody. Also make sure that you got the turbo inlet hose on too. It will cause issues if you're pulling unmetered air into the system too.

My name is Ken and I am a HP Junkie.
Kjott21 is offline  
post #14 of 23 Old 02-15-2007, 07:44 PM
WRXtuners Member
 
Join Date: Feb 2007
Location: California
Posts: 23
wcjuggalo is an unknown
what kid of blow off valve are you running. i had the same problem once and my bov cam apart. some aftermarket ones swivel for clearence, and the set screw comes lose causing a boost leak.
wcjuggalo is offline  
post #15 of 23 Old 02-15-2007, 08:12 PM Thread Starter
WRXtuners Member
 
Join Date: Feb 2007
Location: Florida
Posts: 7
wrxsm is an unknown
there was a blitz on there but too everything back to stock to help eliminate problems so now there is a stock blow off valve
wrxsm is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On