p2102 - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 07-26-2008, 11:15 PM Thread Starter
WRXtuners Member
 
Join Date: Jul 2008
Location: Georgia
Posts: 1
para83 is an unknown
p2102

Im trying to solve this and I think I almost got it. I got a P2102 cel (throttle acctuator motor circuit low). It looks like I need to replace the throttle body but I want to make sure. When driving the first three gears the throttle sound fine. When in 4th its ok if i baby but when you give it some gas like to try topass someone quickly it will shoot up to about 5300 RPM and seems to lag as if its not going anywhere. also if u dont let the gas i smell a faint burning that i cant tell what it smells like.just wanted to make sure this p2102 cel is the cause before i drop of $500 on a new throttle. Any answers? I took the throttle out couldnt find anything wrong but i know its a sealed. Nobody knows the problem
para83 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-27-2008, 02:01 AM
Moderator
 
newtothegame's Avatar
 
Join Date: Dec 2006
Location: Maryland
Posts: 6,493
Images: 4
newtothegame is known to be trustworthy and helpful newtothegame is known to be trustworthy and helpful
Send a message via Yahoo to newtothegame
Do you have any mods done to the car? Is it a standard? It kind of sounds like the clutch might be slipping also.

Joshua
"2007 WRX- PPG'd, 20G- Tim Bailey tuned
Stage 2 2005 WRX
Cobbtuning.com"
newtothegame is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome