P0302 Missfire code - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
#1 Old 12-18-2012, 10:11 PM
WRXtuners Member
 
Join Date: May 2012
Location: Oregon
Posts: 10
Sgorman13 is an unknown
P0302 Missfire code

my wife owns a 2002 WRX, the car is all stock except for a K&N stock replacement filter. A week ago the P0302 code came up, i did a lot of research and figured it might be the coil pack. the car had NO hesitation, sometimes it would be hard to start and sometimes a small engine shake when idling, but nothing major or during driving. 2 days ago i replaced the spark plugs to NGK iridium, made sure they were gapped to .030. at the same time i switched what i thought was coil pack 2 to 4. (if your looking at the engine compartment from outside the car, cylinders 2 and 4 are on the right side correct?) So today the car threw the same engine code so if i got the cylinders correct then its not the coil pack. the car does seem to be running much smoother. would my next bet to be to get a compression test and maybe have the injectors looked at or can i do anything else to it by myself to see whats wrong. thanks guys
Sgorman13 is offline  
Sponsored Links
Advertisement
 
#2 Old 12-19-2012, 05:30 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Could be bad gas. You still on the same tank?

Flush some b12 in with the next tank to see if it subsides.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#3 Old 12-19-2012, 08:50 AM
WRXtuners Member
 
Join Date: May 2012
Location: Oregon
Posts: 10
Sgorman13 is an unknown
no different tanks of gas, ill try some B12 though and report back, thanks
Sgorman13 is offline  
#4 Old 12-19-2012, 09:40 AM
WRXtuners Member
 
Join Date: May 2012
Location: Oregon
Posts: 10
Sgorman13 is an unknown
By the way the spark plugs I took out looked good, none too lean or too rich. Can someone verify cylinder 2 is on the right side if your looking at the engine from outside car?
Sgorman13 is offline  
#5 Old 12-19-2012, 01:40 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Firing order is 1-3-2-4

front of car
2 |[]-I-[]| 1
| I |
4 |[]-I-[]| 3

Rear of car

So yes. Standing in front of the car, the right side is 2 and 4 (2 being the closest to you and 4 being closest to the driver).

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#6 Old 12-27-2012, 07:35 PM
WRXtuners Member
 
Join Date: May 2012
Location: Oregon
Posts: 10
Sgorman13 is an unknown
well so far so good, the B12 seems to have worked, its been a week and no CEL. thanks for the info about that
Sgorman13 is offline  
#7 Old 12-28-2012, 05:58 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
I'd stand clear of that station from now on.

Subies are snobs for fuel.

Glad it worked out.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#8 Old 11-24-2013, 09:55 PM
WRXtuners Member
 
Join Date: May 2012
Location: Oregon
Posts: 10
Sgorman13 is an unknown
well the code has been back for a while, I switched coil packs and it didn't follow the coil pack, I've put a lot of B12 through it over the last 6 months. I cleaned up all the electrical grounds and battery terminals because I read that might be the cause and it still comes back. The car doesn't seem to drive any different, still drives very smooth. not sure where I should go from here, any help would be appreciated.
Sgorman13 is offline  
#9 Old 11-24-2013, 10:40 PM
WRXtuners Member
 
Brockton's Avatar
 
Join Date: Mar 2013
Location: Illinois
Posts: 306
Brockton is a helpful contributing member
Garage
Spark, air/fuel, and compression are the three things to check for a missfire event. Since you've went over coil/plugs I would start with the injector, it could be clogged or malfunctioning. After that I would get a compression test done, could be a valve or piston rings or a gasket, the compression test should help with that. Good luck and keep us posted.
Brockton is offline  
#10 Old 11-24-2013, 10:52 PM
Premium Member
 
Nathan21's Avatar
 
Join Date: Jun 2013
Location: California
Posts: 550
Images: 7
Nathan21 is an unknown
Also just my 2 cents but check you coil pack wires to make sure there isn't any melting on it from heat! Sometimes to much of change in temp will make it miss fire! Does the code pop up under heavy throttle or on idle or just pop up randomly?!

Nathan
2011 WRX Premium
2012 Fozzy
1979 C3
Anti-BOV Gang!
Nathan21 is offline  
#11 Old 11-25-2013, 12:25 AM
WRXtuners Member
 
Join Date: Mar 2013
Location: Michigan
Posts: 171
n8mcd is a helpful contributing member
You can't gap iridium plugs, you might of bent the wire thin electrode tip... Also, I know you said all stock but I have to ask... Stock flywheel and clutch?

See if switching the plugs around makes the misfire change cyl.
n8mcd is offline  
#12 Old 11-25-2013, 07:08 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Quote:
Originally Posted by n8mcd View Post
You can't gap iridium plugs, you might of bent the wire thin electrode tip... Also, I know you said all stock but I have to ask... Stock flywheel and clutch?

See if switching the plugs around makes the misfire change cyl.
You can re-gap iridiums, just have to be super careful. But good advise about moving the plugs.

If it still doesn't change anything dare I say .... do a compression test.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On