Ok! I have two PROBLEMS !! and i need some help from all you guys!!!!!!!!!!!!!!!!!!!! - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 Old 06-09-2009, 10:17 PM Thread Starter
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 49
alexxxphilly is an unknown
Send a message via AIM to alexxxphilly
Ok! I have two PROBLEMS !! and i need some help from all you guys!!!!!!!!!!!!!!!!!!!!

I just got my subaru so i dont know that much of how they act!

1- i put gas today and 2 mins later pop!!! "check engine" came on! yes i used cheap 87 could that be the problem?


2- and most important!! :

my speedo dont work. at all. so i have to change it. can i buy a 04-05 subaru impreza Gauge Cluster Speedometer ? will it fit and work fine? mines its a 2002 wrx.
its cheap, everything works and has a few less miles then mine thats all... will a 04-5 work on my 02?

Please help!
alexxxphilly is offline  
Sponsored Links
Advertisement
 
post #2 of 24 Old 06-09-2009, 10:29 PM
WRXtuners Member
 
nj kiter's Avatar
 
Join Date: Aug 2008
Location: New Jersey
Posts: 119
nj kiter is an unknown
first problem would be the 87 octane, if i am correct the wrx needs at least 91, but i am not 100 percent sure so double check
second problem is i am pretty sure that you can swap them in but do you research on the swap
nj kiter is offline  
post #3 of 24 Old 06-09-2009, 10:37 PM
WRXtuners Member
 
basco's Avatar
 
Join Date: Aug 2004
Location: South Carolina
Posts: 1,873
basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to
Send a message via AIM to basco Send a message via MSN to basco
yeah the CEL is definitely the crappy gas you put in...in our cars you need to run the best available in your area...and as for the gauge cluster yes you can swap them but just search NASIOC or ScoobyMods.com for the instructions on what you need to do

FP GT35R MoTeC M800 AndrewTech PPG'd Wagon - 513AWHP
06 Mazdaspeed6 280/330
- Matt
basco is offline  
post #4 of 24 Old 06-09-2009, 10:38 PM Thread Starter
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 49
alexxxphilly is an unknown
Send a message via AIM to alexxxphilly
now ill just wait till tanks empty n change n see whats up... but the speedo idk... i realy want to know if i can just buy it n get over with.... buy+plug and go.
alexxxphilly is offline  
post #5 of 24 Old 06-09-2009, 10:59 PM
WRXtuners Member
 
basco's Avatar
 
Join Date: Aug 2004
Location: South Carolina
Posts: 1,873
basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to basco is a WRX expert worth listening to
Send a message via AIM to basco Send a message via MSN to basco
you could just search the forums for an 02-03 cluster and it'll just plug right in

FP GT35R MoTeC M800 AndrewTech PPG'd Wagon - 513AWHP
06 Mazdaspeed6 280/330
- Matt
basco is offline  
post #6 of 24 Old 06-09-2009, 11:11 PM Thread Starter
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 49
alexxxphilly is an unknown
Send a message via AIM to alexxxphilly
true... just the 04-05 look a lil better. but i dont feel like doin all the work and at the end not working lol so ill prly end up doing that get a 02 haha
alexxxphilly is offline  
post #7 of 24 Old 06-10-2009, 12:11 AM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
You are crazy for not getting that gas out of the tank. You are doing all this work to your car, I would really hate to see your engine take a dump because you decided to run it till it empties.

I would see if you could maybe put a couple of gallons of 100 octane (if you could find some) and really stay out of boost and refrain from WOT fun.

rollin on 17's now and they're dirty
baller_v24 is offline  
post #8 of 24 Old 06-10-2009, 10:45 AM
WRXpert
 
dumdum's Avatar
 
Join Date: Sep 2004
Location: Virginia
Posts: 2,800
Images: 12
dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention dumdum is a WRX tech God, pay attention
You need to get the DTC read and your problem could be the Vehicle Speed Sensor and not the gauge cluster........

Homebrewed tuned with Opensource!
dumdum is offline  
post #9 of 24 Old 06-10-2009, 03:41 PM Thread Starter
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 49
alexxxphilly is an unknown
Send a message via AIM to alexxxphilly
I know... so all you guys only use 89 or 91? never ever 87?
and the clauster oh well i just get a new one not biggie..
alexxxphilly is offline  
post #10 of 24 Old 06-10-2009, 04:05 PM
WRXtuners Member
 
Kyole's Avatar
 
Join Date: Feb 2009
Location: Ohio
Posts: 76
Images: 3
Kyole is an unknown
with the gas issue, instead of searching for 100 octane and running more of the crappy 87 through your engine, you could buy some octane booster additive and see if it helps...not too sure if it would or not. just my two cents
Kyole is offline  
post #11 of 24 Old 06-10-2009, 04:08 PM
WRXtuners Member
 
baller_v24's Avatar
 
Join Date: Oct 2006
Location: Texas
Posts: 1,469
baller_v24 is known to be trustworthy and helpful baller_v24 is known to be trustworthy and helpful
Send a message via Yahoo to baller_v24
Quote:
Originally Posted by alexxxphilly View Post
I know... so all you guys only use 89 or 91? never ever 87?
and the clauster oh well i just get a new one not biggie..
If 93 octane is in your area do not use anything less than that. If not, don't use less than 91.

rollin on 17's now and they're dirty
baller_v24 is offline  
post #12 of 24 Old 06-10-2009, 05:17 PM Thread Starter
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 49
alexxxphilly is an unknown
Send a message via AIM to alexxxphilly
GOT itttt.... never makin that mistake again
alexxxphilly is offline  
post #13 of 24 Old 06-10-2009, 06:40 PM
WRXtuners Member
 
03 CrazyTaxi's Avatar
 
Join Date: Jan 2006
Location: Missouri
Posts: 728
Images: 4
03 CrazyTaxi is known to be trustworthy and helpful 03 CrazyTaxi is known to be trustworthy and helpful
Send a message via MSN to 03 CrazyTaxi Send a message via Yahoo to 03 CrazyTaxi
You are going to destroy the motor by putting 87 in. ANY forced induction (turbo/SC/whatever) has to run a higher octane. Minimum on the WRX/STIs is 90, if not you WILL have detonation and be looking for a new motor or a new car. Octane boosters WILL NOT work. Drain the tank, fill it with the good stuff. Next time, do your research before buying a turbo car and you won't have this problem.

As for the CEL, get it read at AutoZone or some other generic parts store and post the code.

VF34'd Corvette Killer aka Doug
03 CrazyTaxi is offline  
post #14 of 24 Old 06-10-2009, 09:10 PM
WRXtuners Member
 
jed344's Avatar
 
Join Date: Feb 2009
Location: Iowa
Posts: 147
Images: 3
jed344 is an unknown
i have never even ran 87 in any vehical i run 92 ### thats best i can get were i live:P
jed344 is offline  
post #15 of 24 Old 06-11-2009, 12:08 AM Thread Starter
WRXtuners Member
 
Join Date: May 2009
Location: Pennsylvania
Posts: 49
alexxxphilly is an unknown
Send a message via AIM to alexxxphilly
BEFORE my subbi i had a 95 talon turbo awd. and used 87 for 2 years... ran like a champ... n still does. thats why i didnt care bout putin 87 on my wrx. with a TURBO""" but got it... the wrx cnt take cheap gas then aint puttin cheap gas. thats all...
alexxxphilly is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On