OBD-II problem - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-03-2004, 12:34 AM Thread Starter
WRXtuners Member
 
Join Date: Apr 2004
Location: Washington
Posts: 5
faststi is an unknown
OBD-II problem

I have an 04 STI, when I hooked up my snap on scanner to scan the CEL i have no communication with the ECU. I'm not able to get into the factory ECU to verify that my CEL is caused by the replacement performace exhaust system(no cats). Is there another way of pulling codes out of the system or do you have to hook something else up(like a connector) to allow the scanner to communicate with the ECU. i am planning on putting on a o2 sim as soon as i can verify the code in the system.

Thanks For The Input

-Steve
faststi is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 05-03-2004, 11:04 AM
WRXtuners Member
 
BlueDemon's Avatar
 
Join Date: Apr 2003
Location: Florida
Posts: 1,223
Images: 7
BlueDemon is known to be trustworthy and helpful BlueDemon is known to be trustworthy and helpful
Send a message via AIM to BlueDemon
Its hard to understand what you are getting at. All I know is that with my OBDII Scanner I have an OBD II connector cable that plugs in under then Steering wheel, which then goes into my palm pilot. You then have to sync the OBD II program with your ECUs OBD II Signal. If you already have the cable that plugs in under the steering wheel and you still don't have a connection, either you have the wrong type of connector, the wrong program, or some other software problem. The only other thing it could be is that the 04s use a different system. That's all I can think of.

Blue
BlueDemon is offline  
post #3 of 3 Old 05-03-2004, 12:20 PM Thread Starter
WRXtuners Member
 
Join Date: Apr 2004
Location: Washington
Posts: 5
faststi is an unknown
i service the car collision industry and have used this tool on other cars many times. the snap on tool is an odb-II generic scanner i know that i have the right connections the only thing that i can think of is that the 04's are somewhat different. i can clear the light buy disconnecting the battery for a few minutes. Is there another way on the subarus to get codes without the scanner?
thanks
faststi is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On