No injector pulse or spark?? - Subaru WRX Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 Old 10-11-2013, 08:00 PM
WRXtuners Member
 
Join Date: Oct 2013
Location: New Mexico
Posts: 31
Images: 2
STravis is an unknown
No injector pulse or spark??

I have an 04 wrx that I bought as a project. All the injectors have power but only the injector on cylinder 1 has a pulse. None of the other injectors have a pulse. Where are the grounds for the injectors? What else could the problem be?
STravis is offline  
Sponsored Links
Advertisement
 
#2 Old 10-11-2013, 08:48 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
have you pulled each one and tested them? might be clogged

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#3 Old 10-11-2013, 10:42 PM
WRXtuners Member
 
Join Date: Oct 2013
Location: New Mexico
Posts: 31
Images: 2
STravis is an unknown
Quote:
Originally Posted by pzr2874 View Post
have you pulled each one and tested them? might be clogged
I have pulled the plugs off of the injectors and every plug has 12 volts but no ground to produce the pulse. The only injector plug that gets a pulse is on cylinder 1.
STravis is offline  
#4 Old 10-13-2013, 03:08 PM
WRXtuners Member
 
Join Date: Oct 2013
Location: New Mexico
Posts: 31
Images: 2
STravis is an unknown
bump..
STravis is offline  
#5 Old 10-14-2013, 05:40 AM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Ok, what made you pull the injectors? Because not running? Because cleaning?

edit: found other thread

Electical and vacuum help please.

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#6 Old 10-17-2013, 06:06 PM
WRXtuners Member
 
Join Date: Oct 2013
Location: New Mexico
Posts: 31
Images: 2
STravis is an unknown
Update: the plugs actually do have spark, just no injector pulse.
STravis is offline  
#7 Old 10-17-2013, 08:42 PM
WRXtuners Member
 
Join Date: Oct 2013
Location: New Mexico
Posts: 31
Images: 2
STravis is an unknown
Bump...any ideas on what to check for injector pulse??
STravis is offline  
#8 Old 10-17-2013, 09:05 PM
WRXtuners Member
 
Join Date: Jun 2007
Location: Texas
Posts: 4,970
pzr2874 is known to be trustworthy and helpful pzr2874 is known to be trustworthy and helpful
Try another set? Or just one. Have you tried cleaning them yet?

Paul
2007 XT
2007 MS3
pzr2874 is offline  
#9 Old 10-17-2013, 09:07 PM
WRXtuners Member
 
Join Date: Oct 2013
Location: New Mexico
Posts: 31
Images: 2
STravis is an unknown
There is no pulse to the plug. I have a test light and it isn't flashing when the engine is cranking.
STravis is offline  
#10 Old 10-20-2013, 12:29 PM
WRXtuners Member
 
Join Date: Oct 2013
Location: New Mexico
Posts: 31
Images: 2
STravis is an unknown
ttt..
STravis is offline  
#11 Old 10-23-2013, 01:04 PM
WRXtuners Member
 
Join Date: Oct 2013
Location: New Mexico
Posts: 31
Images: 2
STravis is an unknown
If I found a replacement ecu out of the same year, transmission, and the ecu had the same part # would I need to take it to a Subaru dealership to have it programmed or should I be able to just swap it in and try it?
STravis is offline  
#12 Old 10-23-2013, 01:41 PM
WRXtuners Member
 
Haw1es's Avatar
 
Join Date: Feb 2013
Location: Maine
Posts: 214
Haw1es is more helpful than not
Garage
If all the parts are the same,ie it came from a stock ej207 and you have a stock ej207 I think all you would need is to swap the 2 units.

Shane
2010 WRX
2003 Jetta 2.5
Haw1es is offline  
#13 Old 10-23-2013, 03:49 PM
WRXtuners Member
 
turmic's Avatar
 
Join Date: Jul 2007
Location: Pennsylvania
Posts: 4,371
Images: 6
turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to turmic is a WRX expert worth listening to
Send a message via AIM to turmic
Why would the ECU fix it?

Kirt
378awhp/373wtq Custom Dom 3 & CBRD tuned 2006 STI.
"When in doubt...flat out" - Colin McRae
turmic is offline  
#14 Old 10-23-2013, 08:37 PM
WRXtuners Member
 
psinuse's Avatar
 
Join Date: Nov 2004
Location: Ohio
Posts: 3,005
psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to psinuse is a WRX expert worth listening to
Did you check the fuse for the injectors?

Resident Grumpy Old Man(Keith)
03 SRP 2.34L
08' LGT Gears...
psinuse is offline  
#15 Old 10-23-2013, 08:49 PM
WRXtuners Member
 
BLAZE2099's Avatar
 
Join Date: Jan 2011
Location: Pennsylvania
Posts: 2,567
Images: 6
BLAZE2099 is known to be trustworthy and helpful BLAZE2099 is known to be trustworthy and helpful
Garage
Recent engine bay pic please

Randy-
2002 blaze WRX- sold:(
2004 Wrx-sold
2011 Wrx limited
99 Fozz- sold
Eagle eye crew
BLAZE2099 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On