Subaru WRX Forum

Subaru WRX Forum (http://www.wrxtuners.com/forums/)
-   Problem Diagnosis (http://www.wrxtuners.com/forums/f72/)
-   -   No injector pulse or spark?? (http://www.wrxtuners.com/forums/f72/no-injector-pulse-spark-40194/)

STravis 10-11-2013 08:00 PM

No injector pulse or spark??
 
I have an 04 wrx that I bought as a project. All the injectors have power but only the injector on cylinder 1 has a pulse. None of the other injectors have a pulse. Where are the grounds for the injectors? What else could the problem be?

pzr2874 10-11-2013 08:48 PM

have you pulled each one and tested them? might be clogged

STravis 10-11-2013 10:42 PM

[quote=pzr2874;372978]have you pulled each one and tested them? might be clogged[/quote]

I have pulled the plugs off of the injectors and every plug has 12 volts but no ground to produce the pulse. The only injector plug that gets a pulse is on cylinder 1.

STravis 10-13-2013 03:08 PM

bump..

pzr2874 10-14-2013 05:40 AM

Ok, what made you pull the injectors? Because not running? Because cleaning?

edit: found other thread

[url]http://www.wrxtuners.com/forums/f72/electical-vacuum-help-please-39969/[/url]

STravis 10-17-2013 06:06 PM

Update: the plugs actually do have spark, just no injector pulse.

STravis 10-17-2013 08:42 PM

Bump...any ideas on what to check for injector pulse??

pzr2874 10-17-2013 09:05 PM

Try another set? Or just one. Have you tried cleaning them yet?

STravis 10-17-2013 09:07 PM

There is no pulse to the plug. I have a test light and it isn't flashing when the engine is cranking.

STravis 10-20-2013 12:29 PM

ttt..

STravis 10-23-2013 01:04 PM

If I found a replacement ecu out of the same year, transmission, and the ecu had the same part # would I need to take it to a Subaru dealership to have it programmed or should I be able to just swap it in and try it?

Haw1es 10-23-2013 01:41 PM

If all the parts are the same,ie it came from a stock ej207 and you have a stock ej207 I think all you would need is to swap the 2 units.

turmic 10-23-2013 03:49 PM

Why would the ECU fix it? WTF

psinuse 10-23-2013 08:37 PM

Did you check the fuse for the injectors?

BLAZE2099 10-23-2013 08:49 PM

Recent engine bay pic please


All times are GMT -5. The time now is 06:54 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.

User Alert System provided by Advanced User Tagging v3.0.8pl1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.