New to your WRX, running low boost and can't figure out why? - Subaru WRX Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-19-2012, 11:56 PM Thread Starter
WRXtuners Member
 
Join Date: Sep 2012
Location: Massachusetts
Posts: 8
Cory51191 is an unknown
New to your WRX, running low boost and can't figure out why?

I was having a problem with the amount of boost I was running. My boost gauge would read about 6psi on a strong pull. The owner of the vehicle told me the turbo was shot when I purchased my WRX. So I pulled the TMIC and DP off to check for shaft play and to make sure the turbine spun freely. Nothing was wrong with it. I was scratching my head all night thinking I'd have to get it diagnosed at a Subaru dealership. It was the easiest fix and can be easily overlooked. The last owner put a MBC on the car and must have replaced the vacuum line not knowing there was a tiny but important piece in the original hose.

Take "line 1" off and check for the pill restrictor (PART # 22326 KA120. This is for an 02' WRX, im not sure if it's the same for other models).
You can do this by (1) simply straightening the hose and looking through it. Or (2) bending it throughout the entire length of the hose and feeling for the restrictor.

Quote:
Originally Posted by psinuse View Post
What does a pill restrictor look like?: http://img.photobucket.com/albums/v4...N1689Small.jpg

You can pick one up for a few dollars.

Pill restrictor direction: If you have to insert one on your own, the longer side of the pill points toward the turbo.. That's how they are inserted from the factory.

Last edited by Cory51191; 09-20-2012 at 12:31 PM.
Cory51191 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On